Bug 509229 - Firefox online HTML5 Video Choppy
Firefox online HTML5 Video Choppy
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 16:18 EDT by Bruce Brackbill
Modified: 2009-07-05 21:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-04 03:04:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Choppy Firefox online HTML5 Video (749.18 KB, audio/ogg)
2009-07-01 16:18 EDT, Bruce Brackbill
no flags Details
video of choppy video workaround (1.14 MB, audio/ogg)
2009-07-03 22:51 EDT, Bruce Brackbill
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 462667 None None None Never
Mozilla Foundation 499554 None None None Never

  None (edit)
Description Bruce Brackbill 2009-07-01 16:18:08 EDT
Created attachment 350185 [details]
Choppy Firefox online HTML5 Video

Description of proble:
ogg video in firefox is choppy.

Version-Release number of selected component (if applicable):
firefox-3.5-1.fc11.i586.rpm  xulrunner-1.9.1-2.fc11.i586.rpm
nspr-4.8-1.fc11.i586.rpm

How reproducible:
Play any online ogg video in firefox and its choppy.

Steps to Reproduce:
1.as an example goto http://tinyvid.tv/show/lbc3mt47kiny 
2. play video
  
Actual results:
Choppy video

Expected results:
Not choppy video

Additional info:
Does not matter what video website i visit, just using tinydid.tv as an example

Attached is a video i took of the screen to show you what is happening.
Ignore the Noscript at the bottom of the video, same choppiness with noscript disabled.
Here is my hardware:
http://www.smolts.org/show?uuid=pub_469716df-93a1-4436-992b-4081a3b7780b

My guess is that the video is not being cached very well by the html5 video capabilities of firefox
Comment 1 Matěj Cepl 2009-07-03 12:12:01 EDT
My bets are that you have some problems with caching of the file. Before actually running the picture, let it download completely (UI is not very good for it, but there is a thermometer when you hover above the image with mouse). Only then try to run the clip. Does it help?
Comment 2 Bruce Brackbill 2009-07-03 17:22:12 EDT
Matej,

Thanks for your comment.

Maybe it is a caching problem but it appears that it is not since letting it download completely does not fix the problem.

I have found that I am able to work around the problem by grabbing and moving the cursor to a different place on the timeline (thermometer as you called it ). The video then starts to play smoothly. It does not matter if the video is  downloaded completely or not for this workaround to work as long as I move the cursor to a place on the timeline that has already been downloaded.  I hope that I've described this clearly :-)
Comment 3 Bruce Brackbill 2009-07-03 17:40:43 EDT
I just tested this using local files and the embedded video tag:
<video src='mylocalfile.ogg' controls='controls'></video>

Problem persists ( no matter which ogg file I use ) and the workaround still works.
Comment 4 Matěj Cepl 2009-07-03 18:04:27 EDT
OK, then I feel persuaded :) Other evasive excuse could be your hardware. What's your computer CPU, RAM?

However, truth to be told, this bug belong to the upstream bugzilla. Please file a bug report in the the upstream bugzilla located at http://bugzilla.mozilla.org.

Once you've filed your bug report to the upstream bugzilla, if you paste the new bug URL here, we will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Setting status to NEEDINFO, and awaiting upstream bug report URL for tracking.

Thanks in advance.
Comment 5 Bruce Brackbill 2009-07-03 20:44:11 EDT
I've made a comment to what may be the upstream bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=462667
Comment 6 Bruce Brackbill 2009-07-03 22:51:31 EDT
Created attachment 350470 [details]
video of choppy video workaround

In this attached video I am applying the workaround, (at about the 22 second mark) which as I stated in a previous comment is just simply dragging the cursor a bit. 

This is a local file, so the video is loaded immediately, therefore it does not matter if I drag the cursor to the left or right to get the video and sound to play correctly.
Comment 7 Matěj Cepl 2009-07-04 03:04:52 EDT
OK, joining the upstream bug (https://bugzilla.mozilla.org/show_bug.cgi?id=462667).

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.
Comment 8 Matěj Cepl 2009-07-05 21:24:42 EDT
OK, actually apparnetly it is more likely https://bugzilla.mozilla.org/show_bug.cgi?id=499554 (the previous one was for not that powerfull computers as mine dual core 2.5GHz, 4GB RAM beast).

Note You need to log in before you can comment on or make changes to this bug.