Bug 509234 - Please enable building System.dll plugin
Please enable building System.dll plugin
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mingw32-nsis (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 16:36 EDT by Stu Tomlinson
Modified: 2011-01-03 12:33 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.45-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-27 17:32:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to enable building System.dll (1.42 KB, patch)
2009-07-01 16:36 EDT, Stu Tomlinson
no flags Details | Diff

  None (edit)
Description Stu Tomlinson 2009-07-01 16:36:51 EDT
Created attachment 350190 [details]
Patch to enable building System.dll

The current Fedora build of mingw32-nsis disables building the System.dll plugin, because it contain(ed) "inline Microsoft assembler code"

Thanks to the efforts of the Debian project, that code was replaced in NSIS 2.42, and System.dll can be built natively with GCC in NSIS 2.42 and newer.

I've attached a simple patch against Fedora CVS for the spec file.
Comment 1 Kevin Kofler 2009-07-21 00:01:41 EDT
Updated packages built for F10, F11 and Rawhide.
Comment 2 Fedora Update System 2009-07-21 00:02:46 EDT
mingw32-nsis-2.45-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/mingw32-nsis-2.45-1.fc11
Comment 3 Fedora Update System 2009-07-21 00:03:28 EDT
mingw32-nsis-2.45-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/mingw32-nsis-2.45-1.fc10
Comment 4 Fedora Update System 2009-07-23 15:15:19 EDT
mingw32-nsis-2.45-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mingw32-nsis'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7972
Comment 5 Fedora Update System 2009-07-27 17:32:44 EDT
mingw32-nsis-2.45-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2009-07-27 17:34:52 EDT
mingw32-nsis-2.45-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2010-12-17 04:18:07 EST
mingw32-nsis-2.46-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/mingw32-nsis-2.46-1.el5
Comment 8 Fedora Update System 2011-01-03 12:33:12 EST
mingw32-nsis-2.46-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.