Bug 509237 - gnomecatalog doesn't show catalog
gnomecatalog doesn't show catalog
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnomecatalog (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Marc Wiriadisastra
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 16:39 EDT by Alexander Ovcharenko
Modified: 2009-12-17 23:28 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.3.4.2-3.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-28 22:56:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (582 bytes, patch)
2009-10-10 09:49 EDT, Alexander Ovcharenko
no flags Details | Diff

  None (edit)
Description Alexander Ovcharenko 2009-07-01 16:39:52 EDT
Description of problem:
When I start gnomecatalog it creates the file /tmp/tmp_gnomecatalog_icon.png and it doesn't delete this file after exit. If other user starts gnomecatalog later it doesn't show catalog because unable to delete file. But if I delete this file manually, every user can start gnomecatalog and catalog is shown.

Version-Release number of selected component (if applicable):
gnomecatalog-0.3.4.2-1.fc11

Steps to Reproduce:
1. Start gnomecatalog
2. Add a new disk to the catalog
3. Save the catalog as file to the shared directory
4. Close gnomecatalog
5. Start gnomecatalog as another user
6. Try to open saved catalog. The catalog isn't shown
7. After exit you will see error in logs
  
Additional info:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/gnomecatalog/data.py", line 69, in load_data
    data = self.db.read_data()
  File "/usr/lib/python2.6/site-packages/gnomecatalog/storage.py", line 371, in read_data
    data.append(fstypes.Disk(c["name"],  c["root"], c["id"], self, c["idcatalog"], c["icon"], c['comment'], c['borrow']))
  File "/usr/lib/python2.6/site-packages/gnomecatalog/fstypes.py", line 147, in __init__
    open('/tmp/tmp_gnomecatalog_icon.png', 'wb').write(icon)
IOError: [Errno 13] Permission denied: '/tmp/tmp_gnomecatalog_icon.png'
Comment 1 Marc Wiriadisastra 2009-07-01 19:33:39 EDT
I would think this is a permission issue as the other user doesn't have permission to open someone else's file. 

Have you tried doing the following.

chmod 777 yourgnomecatalog.catalog

which should give permission for everyone to use that file and then try opening it by that other user.
Comment 2 Alexander Ovcharenko 2009-07-02 14:25:02 EDT
(In reply to comment #1)
> I would think this is a permission issue as the other user doesn't have
> permission to open someone else's file. 

No. As I wrote above "if I delete this file (/tmp/tmp_gnomecatalog_icon.png) manually, every user can start gnomecatalog and the catalog is shown"

> Have you tried doing the following.
> 
> chmod 777 yourgnomecatalog.catalog
> 
> which should give permission for everyone to use that file and then try opening
> it by that other user.  

My catalog file "gnomeCatalog.db" has following permissions -rw-rw-r-- and the file is located in shared directory.

I tried "chmod 777 gnomeCatalog.db" but nothing changed.
Comment 3 Alexander Ovcharenko 2009-10-10 09:49:38 EDT
Created attachment 364343 [details]
Proposed patch

Here is my patch for gnomecatalog. It works for me.
Comment 4 Fedora Update System 2009-10-22 06:55:03 EDT
gnomecatalog-0.3.4.2-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gnomecatalog-0.3.4.2-3.fc11
Comment 5 Fedora Update System 2009-10-22 06:55:42 EDT
gnomecatalog-0.3.4.2-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gnomecatalog-0.3.4.2-3.fc10
Comment 6 Fedora Update System 2009-10-27 02:45:36 EDT
gnomecatalog-0.3.4.2-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnomecatalog'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10766
Comment 7 Fedora Update System 2009-10-27 03:11:56 EDT
gnomecatalog-0.3.4.2-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnomecatalog'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-10839
Comment 8 Fedora Update System 2009-10-28 22:56:16 EDT
gnomecatalog-0.3.4.2-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2009-10-28 22:56:37 EDT
gnomecatalog-0.3.4.2-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2009-11-17 18:59:25 EST
gnomecatalog-0.3.4.2-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gnomecatalog-0.3.4.2-3.fc12
Comment 11 Fedora Update System 2009-12-17 23:28:49 EST
gnomecatalog-0.3.4.2-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.