Bug 509244 - uses GraphicsMagick during build to generate icons
uses GraphicsMagick during build to generate icons
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 16:53 EDT by Bill Nottingham
Modified: 2014-03-16 23:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-02 06:44:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2009-07-01 16:53:23 EDT
While that's not technically a *bug*:

[notting@nostromo: ~]$ repoquery -q --repoid rawhide-source --archlist src --whatrequires ImageMagick | wc -l
89
[notting@nostromo: ~]$ repoquery -q --repoid rawhide-source --archlist src --whatrequires GraphicsMagick | wc -l
1

If it doesn't need anything GraphicsMagick-specific, it simplifies the build chain to use the same thing everything else does.

Version-Release number of selected component (if applicable):

qt-4.5.2-2
Comment 1 Kevin Kofler 2009-07-01 17:03:50 EDT
This is intentional. From the Phonon changelog (where these icons were originally generated, before it moved to qt because we're now using Qt's Phonon to avoid the circular dependency):

* Wed May 20 2009 Rex Dieter <rdieter@...> - 4.3.1-5
- s/ImageMagick/GraphicsMagick/, avail on more secondary archs, is faster,
  yields better results.

In addition, it looks like this also prevents multilib conflicts. For some reason, ImageMagick generated different files on the different arches.

That said, if you want to use ImageMagick instead in RHEL, that's fine.
Comment 2 Kevin Kofler 2009-07-02 05:52:33 EDT
I just chatted with Than about this: we will just be pregenerating the PNGs instead of regenerating them on each build. Even the official Oxygen icons are done that way.
Comment 3 Ngo Than 2009-07-02 06:44:17 EDT
it's fixed in qt-4_5_2-3_fc12

Note You need to log in before you can comment on or make changes to this bug.