Bug 509263 - sometimes gdm login doesn't show login name input field
sometimes gdm login doesn't show login name input field
Status: CLOSED DUPLICATE of bug 521833
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 18:03 EDT by Martin F
Modified: 2015-01-14 18:23 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-22 16:24:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin F 2009-07-01 18:03:28 EDT
Description of problem:
Sometimes when machine is turned on and gdm window/dialog appears, 'Other..' item is selected but no text field appears for login name entry. The only button shown is 'Cancel'. The only way to login is to press Cancel until the proper login window/dialog is shown. Pressing on 'Other..' has no effect.

In other cases after booting the proper login window/dialog appears: both the 'Other..' selection and the loginname text field appears, with both 'Login' and 'Cancel' buttons.

Version-Release number of selected component (if applicable):
gdm-2.26.1-10.fc11.x86_64
kernel-2.6.29.5-191.fc11.x86_64
(have no access to other architectures)

How reproducible:
Sometimes (more often than not), seems random

Steps to Reproduce:
1. Power on Reboot
2. Look at the gdm login dialog
3.
  
Actual results:
'Other..' selection and just one button 'Cancel' appears. No login name field or 'Login' button.

Expected results:
Login name field and 'Login' button should also appear.

Additional info:
I've tested on two machines, and they exhibit the same behavior. One has no local user accounts, and the other has local user accounts plus the user listing is disabled:

gconftool-2 --direct \
     --config-source xml:readwrite:/etc/gconf/gconf.xml.defaults \
     --type bool --set /apps/gdm/simple-greeter/disable_user_list true

They both authenticate remote user accounts through LDAP.

Everything works once login text field appears.
Comment 1 Brian Morrison 2009-08-18 20:42:58 EDT
I upgraded to F11 today, have all the latest updated F11 packages and am also suffering the same problem.

The only way to log in is to click on the cancel button, even though there is nothing to cancel, and that provokes the username box to appear. After that it all works OK.

Happy to provide further debug if what is needed is requested.
Comment 2 Brian Morrison 2009-10-03 14:21:35 EDT
I found that this problem disappeared with the following package:

kernel-2.6.30.5-43.fc11.x86_64

but has returned with this:

kernel-2.6.30.8-64.fc11.x86_64

I looked at the other packages in this set of updates, as far as I can tell none of them should affect gdm although there was a kdm update to:

kdm-4.3.1-9.fc11.x86_64

although I do not use KDE and have not logged in to it on this machine.
Comment 3 Brian Morrison 2009-10-05 17:43:31 EDT
Another day, another round of package updates....these from updates-testing

xorg-x11-server-common.x86_64 1.6.4-0.2.fc11
xorg-x11-server-Xorg.x86_64 1.6.4-0.2.fc11
xorg-x11-drv-intel.x86_64 2.7.0-8.fc11

and this from updates

gnome-settings-daemon-2.26.1-11.fc11.x86_64

and suddenly gdm is now working properly again.

Not at all clear what really fixed this!
Comment 4 Travers Carter 2009-10-23 22:24:06 EDT
I'm seeing this or something very similar on F12 Beta too with gdm-2.28.0-9.fc12

But I can't seem to get the login name field to appear under any circumstances, the only workaround I've found so far is to set DISPLAYMANAGER=KDE in /etc/sysconfig/desktop.

I think the problem started after I enabled LDAP auth through system-config-authentication.
Comment 5 Sergey Rudchenko 2009-12-22 16:24:44 EST
Thank you for the bug report.

Sorry, but despite your bug report is earlier an another instance of this bug was marked as ASSIGNED and I have to close this as a duplicate. That is a bug triage miss. Thank you for such accurate description.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 521833 ***

Note You need to log in before you can comment on or make changes to this bug.