Bug 509268 - Package amanda-x86 after installation does net get listed in SSM Remove, Upgrade, nor Verify listing
Package amanda-x86 after installation does net get listed in SSM Remove, Upgr...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
high Severity medium
: ---
: ---
Assigned To: Jay Dobies
John Sefler
https://grandprix.rhndev.redhat.com/r...
:
Depends On:
Blocks: 471789
  Show dependency treegraph
 
Reported: 2009-07-01 18:29 EDT by John Sefler
Modified: 2009-09-10 14:44 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:44:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2009-07-01 18:29:48 EDT
Description of problem:
After installing amanda package on a satallite client, 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. For a selected Satellite Client, click "Add to SSM"
2. Click Manage
3. Click Packages: / "Install
4. Click Channel e.g. "Red Hat Enterprise Linux (v. 5 for 64-bit x86_64)"
5. Search for and check the amanda packages and click "Install" and "Install new packages"
6. on client, run "rhn_check -vvv"
7. verify on the client that the package is indeed installed "rpm -qa | grep amanda"
8. On the Satellite, click "Manage"
9. Click Packages: / "Verify"
10. Search for amanda

No results are found by satellite. <--- BUG
I expected the newly installed amanda packages to be listed.
  
Actual results:


Expected results:


Additional info:
Comment 1 Clifford Perry 2009-07-01 21:58:36 EDT
This may be a client issue in sending up information to Satellite, or I guess it could be server side, need to figure it out. 

Giving to Brad for now to review. 

Cliff
Comment 2 Jay Dobies 2009-07-07 16:41:37 EDT
I think this boils down to being a bug in searching for packages on these pages.

I was able to follow the above instructions, getting the package installed and seeing it appear in the Verify Packages table. I installed the "alchemist" package so it was right near the top.

I double checked the code as well. The queries look correct in that the remove/verify package list is generated by looking for all packages that are installed on at least one system in the SSM.

However, when I attempted to search for alchemist using the filter box on that page, I get a message about there being no packages. I don't think this is due to a delay in the search server getting the information as searching for packages that were originally inventoried at registration produced no results as well.

One thing that looks suspect is that the URL changes. When first viewing the page or right after a search, the URL looks like:

https://server/rhn/ssm/PackageVerify.do

After the link that says "Clear filter to see all 403 items", the URL is:

https://server/rhn/ssm/PackageVerify.do?1154021400_PAGE_SIZE_LABEL=25&list_1154021400_filterattr=name&1154021400_PAGE_SIZE_LABEL_SELECTED=null&submitted=true&list_1154021400_sortdir=&list_1154021400_page_last=last&list_1154021400_items=331|133|101~*~acl-2.2.39-3.el5&list_1154021400_filtername=Go&list_1154021400_sortby=&list_1154021400_page_next=1&list_1154021400_all=false&list_1154021400_none=false

I'm guessing this is incorrect in some capacity.

So in summary, I don't think this is an issue with the client, nor with the verify package list generation. I think this is a bug with the server side search implementation on these pages.
Comment 3 Jay Dobies 2009-07-07 16:55:35 EDT
Master
commit	01c5eba213856f5d4050a6ec1e6005edd07749c2
tree	619e8b7dff208a2ea6ff311473f3f5e698a63c3a

Vader
commit	55b77e1445bd7138248c7855feddeeb078714885
tree	523fa33cf1fc4216b5568dddc4cec83d7c21e684

java/code/webapp/WEB-INF/pages/ssm/packageremove.jsp
java/code/webapp/WEB-INF/pages/ssm/packageverify.jsp

Fixed incorrect filterattr values that were causing filters to fail in all cases.
Comment 4 John Sefler 2009-07-16 14:10:17 EDT
Manually verified the problem description steps on:
  Satellite-5.3.0-RHEL5-re20090709.0
Comment 6 Brandon Perkins 2009-09-10 14:44:56 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.