Bug 509287 - The color of the message can not be set both for text and background
The color of the message can not be set both for text and background
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 23:13 EDT by Yewei Shao
Modified: 2010-07-21 09:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-21 09:35:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of non-reproduction with the upstream binary (150.19 KB, image/png)
2009-08-27 19:26 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Yewei Shao 2009-07-01 23:13:16 EDT
Description of problem:
We can not set the text color and background color for a message.

Version-Release number of selected component (if applicable):
thunderbird-3.0-2.3.beta2

How reproducible:everytime


Steps to Reproduce:
1. Launch the thunderbird, and make sure you have a account and some messages in this thunderbird.
2. Go to "Edit -> Preferences -> Display -> Formatting"
3. In the "Colors" Setting, change the text color to a new color not the default black color. Also change the Background color to a new color not the default white color.
4. Click "Close" and view a message
  
Actual results:
The text color is still black and the background color is still white.

Expected results:
Both the text color and the background color should be changed to new color.

Additional info:
Comment 1 Matěj Cepl 2009-07-06 15:56:09 EDT
Can happily reproduce with Fedora packaged thunderbird-3.0-2.4.b3pre.hg.6a6386c16e98.fc11.x86_64, but cannot with upstream binary ("Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.2a1pre) Gecko/20090703 Shredder/3.1a1pre").
Comment 2 Christopher Aillon 2009-08-26 17:02:25 EDT
Please test the equivalent version, Matej.  3.1alpha data is good to have, but more important is to know whether this bug exists in the upstream 3.0beta code.  If so, this should be filed specifically targetting the 3.0 beta.
Comment 3 Christopher Aillon 2009-08-26 17:03:06 EDT
Also, we've had a new package come out since.  Is this still reproducible?
Comment 4 Matěj Cepl 2009-08-27 19:25:38 EDT
OK, still the same ... I can reproduce this issue with thunderbird-3.0-3.8.b3.fc12.x86_64, and cannot with the upstream binary for TB 3.0b3 ("Mozilla/5.0 (X11; U; Linux i686 (x86_64); cs; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3").
Comment 5 Matěj Cepl 2009-08-27 19:26:20 EDT
Created attachment 358982 [details]
screenshot of non-reproduction with the upstream binary
Comment 6 Jan Horak 2009-09-21 10:34:41 EDT
This seems to be problem with --enable-system-cairo (our cairo). When I build Thunderbird without this option I'm unable to reproduce thus bug anymore.
Comment 8 Bug Zapper 2009-11-16 05:35:51 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Fedora Update System 2009-11-25 11:07:08 EST
sunbird-1.0-0.14.20090916hg.fc12,thunderbird-3.0-3.12.rc1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/sunbird-1.0-0.14.20090916hg.fc12,thunderbird-3.0-3.12.rc1.fc12
Comment 10 Fedora Update System 2009-11-25 11:07:28 EST
sunbird-1.0-0.9.20090715hg.fc11,thunderbird-3.0-2.9.rc1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/sunbird-1.0-0.9.20090715hg.fc11,thunderbird-3.0-2.9.rc1.fc11
Comment 11 Fedora Update System 2009-11-27 16:41:30 EST
sunbird-1.0-0.9.20090715hg.fc11, thunderbird-3.0-2.9.rc1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sunbird thunderbird'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-12224
Comment 12 Fedora Update System 2009-11-27 16:53:31 EST
sunbird-1.0-0.14.20090916hg.fc12, thunderbird-3.0-3.12.rc1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sunbird thunderbird'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12269
Comment 13 Fedora Update System 2010-07-21 08:49:59 EDT
thunderbird-3.0.6-1.fc12,sunbird-1.0-0.23.20090916hg.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/thunderbird-3.0.6-1.fc12,sunbird-1.0-0.23.20090916hg.fc12

Note You need to log in before you can comment on or make changes to this bug.