Bug 509290 - Automake 1.11 does not work to compile GNOME modules including Yelp
Automake 1.11 does not work to compile GNOME modules including Yelp
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: automake (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 23:25 EDT by Paul Cutler
Modified: 2009-07-02 05:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-02 05:11:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Cutler 2009-07-01 23:25:15 EDT
Description of problem: GNOME modules Yelp and gnome-doc-utils fail to build on Fedora 11 with the Development group installed, including automake-1.11-2.fc11


Version-Release number of selected component (if applicable):1.11


How reproducible:

Do a git clone from GNOME for Yelp or gnome-doc-utils


Steps to Reproduce:
1. git clone from GNOME for Yelp or gnome-doc-utils
2. run ./autogen.sh
3. autogen.sh fails
  
Actual results:

./autogen.sh 
/usr/bin/gnome-autogen.sh
skipping ./test -- flagged as no auto-gen
checking for autoconf >= 2.53...
  testing autoconf2.50... not found.
  testing autoconf... found 2.63
checking for automake >= 1.9...
  testing automake-1.10... not found.
  testing automake-1.9... not found.
***Error***: You must have automake >= 1.9 installed
  to build Yelp.  Download the appropriate package for
  from your distribution or get the source tarball at
    http://ftp.gnu.org/pub/gnu/automake/automake-1.9.tar.gz

[pcutler@lucien yelp]$ automake --version
automake (GNU automake) 1.11
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv2+: GNU GPL version 2 or later <http://gnu.org/licenses/gpl-2.0.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by Tom Tromey <tromey@redhat.com>
       and Alexandre Duret-Lutz <adl@gnu.org>.

Expected results:

Running ./autogen.sh should work as automake 1.11 is installed, and should create the make files in order to run make and make install 

Additional info:  I need Yelp 2.27.2 and gnome-doc-utils 0.17.2 to write GNOME documentation in Mallard, and rawhide only has Yelp 2.27.1 available, which is why I needed to compile from source
Comment 1 Karsten Hopp 2009-07-02 05:11:50 EDT
It's not a bug in automake if gnome's autogen.sh checks only for automake 1.9 and 1.10 and ignores everything newer.
Try running autoreconf instead of ./autogen.sh, here's a cut&paste from automake's info file:

Many packages come with a script called `bootstrap.sh' or
`autogen.sh', that will just call `aclocal', `libtoolize', `gettextize'
or `autopoint', `autoconf', `autoheader', and `automake' in the right
order.  Actually this is precisely what `autoreconf' can do for you.
If your package has such a `bootstrap.sh' or `autogen.sh' script,
consider using `autoreconf'.

Note You need to log in before you can comment on or make changes to this bug.