Bug 50930 - Keyboard doesn't work in Failsafe mode.
Keyboard doesn't work in Failsafe mode.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
roswell
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-04 20:44 EDT by Bobby Brinkley
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-28 09:19:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bobby Brinkley 2001-08-04 20:44:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
When I start a failsafe session from the kdm login screen, my mouse works; 
however, my keyboard.  The focus is on the console, meaning the cursor is 
in the console.

How reproducible:
Always

Steps to Reproduce:
1.Login on kdm login screen into failsafe session
2.Place focus on the console
3.Try to type in the console.
	

Actual Results:  No ability to type in the failsafe console.  Even when 
focus is on the console.

Expected Results:  Ability to type in the console at the command prompt.

Additional info:
Comment 1 Glen Foster 2001-08-06 18:43:35 EDT
We (Red Hat) should try to fix this for the next release.
Comment 2 Mike A. Harris 2001-08-08 11:42:49 EDT
Don't see how this has anything to do with X...  KDE issue.
Comment 3 Bobby Brinkley 2001-08-08 12:18:19 EDT
See Bug#: 50847 for the assesment by bero@redhat.com, who told me that it was 
an X problem and not a kde problem.
Comment 4 Bernhard Rosenkraenzer 2001-08-10 10:32:45 EDT
I can't reproduce it, and since KDE isn't running, I don't think it's a KDE 
problem.
Might be a usability problem though: Are you aware of the fact that in twm 
(which is used in the failsafe session), you need to move the mouse over the 
window you're trying to type in?
Comment 5 Bobby Brinkley 2001-08-10 11:15:32 EDT
Yes, I am arare that I need to have the mouse cursor over the window that I am 
typing in; however, it doesn't change anything.  The window seems to get the 
focus when the cursor is over the window, but I still cannot type.
Comment 6 Warren Togami 2001-08-13 00:09:28 EDT
This sounds like this is related to the problem I found in Bug 51615.
"Whenever the X server is restarting, either after a CTRL-ALT-Backspace or 
normal logout and subsequent X restart, if you attempt to switch to a 
virtual terminal with CTRL-ALT-F[1-6] during this time, X appears to load 
and display properly.  It does not respond to keyboard input."
Comment 7 Warren Togami 2001-08-14 03:55:09 EDT
(I'm quite sure this is an X problem, not KDE.)
Comment 8 Bernhard Rosenkraenzer 2001-08-20 09:54:34 EDT
Looks a lot like http://bugs.kde.org/db/30/30344.html, by the way.

Comment 9 Mike A. Harris 2002-01-28 06:44:00 EST
Do you still experience this problem in Red Hat Linux 7.2, or our official
erratum release of XFree86 4.1.0-15?  I'm not able to reproduce it yet.

If the problem persists, I'll have to try it on a duplicated setup.
Comment 10 Bobby Brinkley 2002-01-28 08:47:31 EST
No, it doesn't happen in 7.2.  Seems to work fine now.
Comment 11 Mike A. Harris 2002-01-28 09:20:34 EST
Ok, thanks.  Closing bug as fixed in Enigma (7.2).

Note You need to log in before you can comment on or make changes to this bug.