Bug 509304 - X session restarted on switching to VT
X session restarted on switching to VT
Status: CLOSED DUPLICATE of bug 494411
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-02 01:33 EDT by Amit Shah
Modified: 2018-04-11 09:19 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-24 07:57:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (113.20 KB, text/plain)
2009-07-02 01:33 EDT, Amit Shah
no flags Details
/var/log/messages after X killed on resume (16.49 KB, text/plain)
2009-07-17 15:21 EDT, Andrei Gaponenko
no flags Details

  None (edit)
Description Amit Shah 2009-07-02 01:33:34 EDT
Created attachment 350245 [details]
Xorg.0.log

Description of problem:

Running F11, installed from the KDE Live CD on a ThinkPad X200.

On switching to VT (Ctrl+Alt+F2) my running KDE session crashed and I was presented the kdm login screen even while I was typing some commands on the VT.

Attaching Xorg.0.log.old.

snippet for the display adapter from smolt profile:

                (32902:10818:6058:8420) pci, i915, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller                                                                            
                (32902:10819:6058:8420) pci, Unknown, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller                                                                         
                (32902:10816:6058:8416) pci, agpgart-intel, OTHER, Mobile 4 Series Chipset Memory Controller Hub

No relevant messages in the kernel log.
Comment 1 Søren Sandmann Pedersen 2009-07-17 06:53:32 EDT
Were you using compositing when this happened?
Comment 2 Amit Shah 2009-07-17 07:07:53 EDT
I don't think I was.
Comment 3 Andrei Gaponenko 2009-07-17 15:16:39 EDT
Hello,

Regarding composition, the problem happens both with and without it.
I first saw these random kills of X server on a VT switch with KDE
"desktop effects" enabled.  Turning them off (a few weeks ago) did not
make any noticeable difference.

The problem does not happen on every VT switch, it is random. (At
least on my x200s.)  But I have seen it many times by now.  Sometimes
X gets killed and kdm respawns on exiting suspend-to-ram, perhaps the
same problem.  Or on using the "switch user" feature in the menu
instead of pressing Ctrl-Alt-FN.

Looking in /var/log/messages after a recent "killed on resume"
incident I spotted lines like

 kernel: i2c-adapter i2c-2: unable to read EDID block.
 kernel: i915 0000:00:02.0: DVI-D-1: no EDID data

may be related to the crash.  At least I don't see them for a "good"
resume.  (I don't use an external monitor, only the built-in LCD.)
I'll attache an excerpt of /var/log/messages covering the suspend and
resume parts where X was killed on resume.


How can I enable extra debug output to have more information after the
next crash?

Thank you,
Andrei
Comment 4 Andrei Gaponenko 2009-07-17 15:21:44 EDT
Created attachment 354197 [details]
/var/log/messages after X killed on resume

An excerpt from /var/log/messages covering a suspend and resume cycle where KDE session was killed on resume.
Comment 5 Michal Svanda 2009-07-22 16:17:29 EDT
I notices the same behavior with Thinkpad R61 and Intel GM965. Issue was solved installing xorg-drv-intel from Rawhide (via rebuilding Rawhide's package, it asker for an upgrade of libdrm). After doing this desktop (KDE) seems stable after numerous suspends (both to disk and to RAM).

Michal
Comment 6 Matěj Cepl 2009-07-24 07:57:46 EDT

*** This bug has been marked as a duplicate of bug 494411 ***

Note You need to log in before you can comment on or make changes to this bug.