Bug 509361 - A lot of warnings about unknown symbols when installing kvm/kmod-kvm
A lot of warnings about unknown symbols when installing kvm/kmod-kvm
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
All Linux
low Severity low
: rc
: ---
Assigned To: Eduardo Habkost
Lawrence Lim
: Reopened
Depends On: 537331
Blocks: 5.4/TechnicalNotes 5.6-Known_Issues
  Show dependency treegraph
 
Reported: 2009-07-02 09:13 EDT by Michal Nowak
Modified: 2014-03-25 20:58 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The KVM modules from the kmod-kvm package on do not support kernels prior to version 2.6.18-203.el5. If kmod-kvm is updated and an older kernel is kept installed, "unresolved symbols" messages may be shown for the older kernel, similar to the following: WARNING: /lib/modules/2.6.18-194.el5/weak-updates/kmod-kvm/ksm.ko needs unknown symbol kvm_ksm_spte_count
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-06 10:58:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upgrade.log (53.87 KB, text/plain)
2011-01-06 09:47 EST, Alexander Todorov
no flags Details

  None (edit)
Description Michal Nowak 2009-07-02 09:13:04 EDT
Description of problem:

WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/ksm.ko needs unknown symbol kvm_ksm_spte_count
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/ksm.ko needs unknown symbol kvm_anon_inode_getfd
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/ksm.ko needs unknown symbol kvm_ksm_set_pte
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_exit
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_init
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_enable_efer_bits
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_get_msr_common
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_vcpu_uninit
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_emulate_halt
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_lapic_find_highest_irr
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_task_switch
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_enable_tdp
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_disable_tdp
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_queue_exception
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol emulate_instruction
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol fx_init
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_cpu_has_interrupt
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_lapic_get_cr8
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_get_cr8
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_x86_ops
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_vcpu_cache
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_emulate_hypercall
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol load_pdptrs
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_handle_fault_on_reboot
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_mmu_unprotect_page_virt
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_get_cs_db_l_bits
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_mmu_page_fault
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_lapic_set_tpr
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_mmu_reset_context
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_queue_exception_e
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_emulate_cpuid
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_vcpu_init
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_set_msr_common
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_mmu_load
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_cpu_get_interrupt
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-amd.ko needs unknown symbol kvm_emulate_pio
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_clear_guest_page
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_exit
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_init
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_enable_efer_bits
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_mmu_set_nonpresent_ptes
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol gfn_to_page
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol segment_base
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_get_msr_common
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol __kvm_set_memory_region
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_vcpu_uninit
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_emulate_halt
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_set_apic_base
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_report_emulation_failure
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_lapic_find_highest_irr
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_task_switch
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_enable_tdp
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_disable_tdp
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_lmsw
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_set_memory_region
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_queue_exception
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol emulate_instruction
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_write_guest_page
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol fx_init
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_lapic_get_cr8
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_cpu_has_interrupt
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_set_cr3
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_get_cr8
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_x86_ops
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_vcpu_cache
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_emulate_hypercall
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol load_pdptrs
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_handle_fault_on_reboot
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_mmu_unprotect_page_virt
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_set_cr4
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_set_cr0
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_set_cr8
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_lapic_enabled
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_mmu_page_fault
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_mmu_reset_context
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_queue_exception_e
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_emulate_cpuid
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_vcpu_init
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_mmu_invlpg
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_set_msr_common
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_mmu_set_base_ptes
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_cpu_get_interrupt
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_emulate_pio
WARNING: /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/kvm-intel.ko needs unknown symbol kvm_mmu_set_mask_ptes


Perhaps no KVM support in that (old) kernel?


[root@localhost ~]# rpmquery -f /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/ksm.ko
file /lib/modules/2.6.18-146.el5/weak-updates/kmod-kvm/ksm.ko is not owned by any package

[root@localhost ~]# rpmquery kernel
kernel-2.6.18-146.el5
kernel-2.6.18-156.el5

[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.18-156.el5 #1 SMP Mon Jun 29 18:16:54 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

The files named ksm.ko exists in both -146 and -156 kernels but is not owned by any package, which looks to me strange.

Version-Release number of selected component (if applicable):

kvm-83-82.el5
Comment 1 Eduardo Habkost 2009-07-02 15:35:27 EDT
The files not owned by any package are expected.

The modules are built against an specific kernel (the latest kernel available when the kvm package was built), but they are automatically made available to the other installed kernels, too. However, it won't necessarily work against older kernels, and that may explain why you are seeing those warnings.

Check if the problem persist if you uninstall all kernel packages older than 2.6.18-152.el5, keeping only kernel packages newer than 2.6.18-152.el5 installed.
Comment 2 Eduardo Habkost 2009-07-02 15:38:11 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
The KVM modules from the kmod-kvm package don't support kernel packages older than 2.6.18-152.el5. Warning messages may be shown if older kernels are available when kmod-kvm is installed, but it shouldn't impact usage of KVM with kernel 2.6.18-152.el5 or newer.
Comment 3 Michal Nowak 2009-07-03 04:33:36 EDT
I guess we might close this as CURRENTRELEASE because the warnings are present only when kernel < 152.el5 is installed thus this won't be a problem for customers/partners since 155.el5 is in 5.4-beta. However I don't know how about upgrade from 5.3 -> 5.4 -- fix it in 5.4 or not at all, I think.
Comment 5 Eduardo Habkost 2009-07-23 10:14:03 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1 @@
-The KVM modules from the kmod-kvm package don't support kernel packages older than 2.6.18-152.el5. Warning messages may be shown if older kernels are available when kmod-kvm is installed, but it shouldn't impact usage of KVM with kernel 2.6.18-152.el5 or newer.+The KVM modules from the kmod-kvm package don't support kernel packages older than 2.6.18-159.el5. Warning messages may be shown if older kernels are available when kmod-kvm is installed, but it shouldn't impact usage of KVM with kernel 2.6.18-159.el5 or newer.
Comment 6 Gerrit Slomma 2009-07-23 15:34:12 EDT
Upgraded from 5.3 to 5.4b today.
# modprobe kvm 
=> works
# modprobe kvm-intel
=> fails
FATAL: Error inserting kvm_intel (/lib/modules/2.6.18-155.el5/weak-updates/kmod-kvm/kvm-intel.ko): Unknown symbol in module, or unknown parameter (see dmesg)

# dmesg
kvm_intel: disagrees about version of symbol kvm_clear_guest_page
kvm_intel: Unknown symbol kvm_clear_guest_page
kvm_intel: disagrees about version of symbol gfn_to_page
kvm_intel: Unknown symbol gfn_to_page
kvm_intel: disagrees about version of symbol kvm_get_msr_common
kvm_intel: Unknown symbol kvm_get_msr_common
kvm_intel: disagrees about version of symbol __kvm_set_memory_region
kvm_intel: Unknown symbol __kvm_set_memory_region
kvm_intel: disagrees about version of symbol kvm_vcpu_uninit
kvm_intel: Unknown symbol kvm_vcpu_uninit
kvm_intel: disagrees about version of symbol kvm_emulate_halt
kvm_intel: Unknown symbol kvm_emulate_halt
kvm_intel: disagrees about version of symbol kvm_set_apic_base
kvm_intel: Unknown symbol kvm_set_apic_base
kvm_intel: disagrees about version of symbol kvm_report_emulation_failure
kvm_intel: Unknown symbol kvm_report_emulation_failure
kvm_intel: disagrees about version of symbol kvm_lapic_find_highest_irr
kvm_intel: Unknown symbol kvm_lapic_find_highest_irr
kvm_intel: disagrees about version of symbol kvm_task_switch
kvm_intel: Unknown symbol kvm_task_switch
kvm_intel: disagrees about version of symbol kvm_lmsw
kvm_intel: Unknown symbol kvm_lmsw
kvm_intel: disagrees about version of symbol kvm_set_memory_region
kvm_intel: Unknown symbol kvm_set_memory_region
kvm_intel: disagrees about version of symbol kvm_queue_exception
kvm_intel: Unknown symbol kvm_queue_exception
kvm_intel: disagrees about version of symbol emulate_instruction
kvm_intel: Unknown symbol emulate_instruction
kvm_intel: disagrees about version of symbol kvm_write_guest_page
kvm_intel: Unknown symbol kvm_write_guest_page
kvm_intel: disagrees about version of symbol fx_init
kvm_intel: Unknown symbol fx_init
kvm_intel: disagrees about version of symbol kvm_lapic_get_cr8
kvm_intel: Unknown symbol kvm_lapic_get_cr8
kvm_intel: disagrees about version of symbol kvm_cpu_has_interrupt
kvm_intel: Unknown symbol kvm_cpu_has_interrupt
kvm_intel: disagrees about version of symbol kvm_set_cr3
kvm_intel: Unknown symbol kvm_set_cr3
kvm_intel: disagrees about version of symbol kvm_get_cr8
kvm_intel: Unknown symbol kvm_get_cr8
kvm_intel: disagrees about version of symbol kvm_x86_ops
kvm_intel: Unknown symbol kvm_x86_ops
kvm_intel: disagrees about version of symbol kvm_emulate_hypercall
kvm_intel: Unknown symbol kvm_emulate_hypercall
kvm_intel: disagrees about version of symbol load_pdptrs
kvm_intel: Unknown symbol load_pdptrs
kvm_intel: disagrees about version of symbol kvm_mmu_unprotect_page_virt
kvm_intel: Unknown symbol kvm_mmu_unprotect_page_virt
kvm_intel: disagrees about version of symbol kvm_set_cr4
kvm_intel: Unknown symbol kvm_set_cr4
kvm_intel: disagrees about version of symbol kvm_set_cr0
kvm_intel: Unknown symbol kvm_set_cr0
kvm_intel: disagrees about version of symbol kvm_set_cr8
kvm_intel: Unknown symbol kvm_set_cr8
kvm_intel: disagrees about version of symbol kvm_lapic_enabled
kvm_intel: Unknown symbol kvm_lapic_enabled
kvm_intel: disagrees about version of symbol kvm_mmu_page_fault
kvm_intel: Unknown symbol kvm_mmu_page_fault
kvm_intel: disagrees about version of symbol kvm_mmu_reset_context
kvm_intel: Unknown symbol kvm_mmu_reset_context
kvm_intel: disagrees about version of symbol kvm_queue_exception_e
kvm_intel: Unknown symbol kvm_queue_exception_e
kvm_intel: disagrees about version of symbol kvm_emulate_cpuid
kvm_intel: Unknown symbol kvm_emulate_cpuid
kvm_intel: disagrees about version of symbol kvm_vcpu_init
kvm_intel: Unknown symbol kvm_vcpu_init
kvm_intel: disagrees about version of symbol kvm_mmu_invlpg
kvm_intel: Unknown symbol kvm_mmu_invlpg
kvm_intel: disagrees about version of symbol kvm_set_msr_common
kvm_intel: Unknown symbol kvm_set_msr_common
kvm_intel: disagrees about version of symbol kvm_cpu_get_interrupt
kvm_intel: Unknown symbol kvm_cpu_get_interrupt
kvm_intel: disagrees about version of symbol kvm_emulate_pio
kvm_intel: Unknown symbol kvm_emulate_pio

threw out kernels 2.6.18-128.1.10 and 2.6.18-128.1.16 and deleted selfbuilt kvm-85 modules there but to no avail.
Comment 7 Gerrit Slomma 2009-07-23 15:36:34 EDT
Okay, had to delete /lib/modules/2.6.18-155.el5/weak-updates/kvm.ko
was created during upgrade.
may be the same problem at the initial poster?
Comment 8 Eduardo Habkost 2009-07-23 15:45:06 EDT
(In reply to comment #7)
> Okay, had to delete /lib/modules/2.6.18-155.el5/weak-updates/kvm.ko
> was created during upgrade.
> may be the same problem at the initial poster?  

Which kvm package version are you running? For the latest kvm package (kvm-83-94.el5), you need kernel 2.6.18-159.el5 or newer.
Comment 9 Gerrit Slomma 2009-07-23 16:09:54 EDT
etherboot-zroms-kvm.x86_64    5.4.4-10.el5                     
kmod-kvm.x86_64               83-80.el5                        
kvm.x86_64                    83-80.el5                        
kvm-qemu-img.x86_64           83-80.el5
kernel.x86_64                 2.6.18-155.el5
                      

All from the RHN RHEL5.4 beta repository.
But it is working now.
The upgrade-process must not take any kvm-modules from older kernel-releases but it does. I had to delete it by hand as stated than the message disappeared and all was fine.
Comment 12 Ryan Lerch 2009-08-18 00:28:10 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1,5 @@
-The KVM modules from the kmod-kvm package don't support kernel packages older than 2.6.18-159.el5. Warning messages may be shown if older kernels are available when kmod-kvm is installed, but it shouldn't impact usage of KVM with kernel 2.6.18-159.el5 or newer.+The KVM modules from the kmod-kvm package do not support kernels prior to version 2.6.18-159.el5. Error messages similar to the following will be returned if attempting to install these modules on older kernels:
+
+FATAL: Error inserting kvm_intel
+(/lib/modules/2.6.18-155.el5/weak-updates/kmod-kvm/kvm-intel.ko): Unknown
+symbol in module, or unknown parameter (see dmesg)
Comment 14 Alexander Todorov 2011-01-06 09:45:46 EST
I'm seeing those kinds of warnings when upgrading from RHEL5.5 kernel-2.6.18-194 to RHEL 5.6 kernel-2.6.18-238.el5. Re-opening.
Comment 15 Alexander Todorov 2011-01-06 09:47:29 EST
Created attachment 472074 [details]
upgrade.log
Comment 17 Dor Laor 2011-01-06 10:04:04 EST
What's the warning say?
Comment 18 Eduardo Habkost 2011-01-06 10:58:17 EST
This is the same case we had on 5.5, but now involving a different kernel version.

Updating flags and version information so it gets on the 5.6.0 release notes list.
Comment 19 Eduardo Habkost 2011-01-06 10:58:17 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,5 +1,4 @@
-The KVM modules from the kmod-kvm package do not support kernels prior to version 2.6.18-159.el5. Error messages similar to the following will be returned if attempting to install these modules on older kernels:
+The KVM modules from the kmod-kvm package on RHEL-5.6.0 do not support kernels prior to version 2.6.18-203.el5. If kmod-kvm is updated and a older kernel is kept installed, "unresolved symbols" messages may be shown for the older kernel, similar to the following:
+WARNING: /lib/modules/2.6.18-194.el5/weak-updates/kmod-kvm/ksm.ko needs unknown symbol kvm_ksm_spte_count
 
-FATAL: Error inserting kvm_intel
+This shouldn't affect the ability to load the KVM modules when running an up-to-date kernel version.-(/lib/modules/2.6.18-155.el5/weak-updates/kmod-kvm/kvm-intel.ko): Unknown
-symbol in module, or unknown parameter (see dmesg)
Comment 21 Ryan Lerch 2011-01-06 21:40:42 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,4 +1,2 @@
-The KVM modules from the kmod-kvm package on RHEL-5.6.0 do not support kernels prior to version 2.6.18-203.el5. If kmod-kvm is updated and a older kernel is kept installed, "unresolved symbols" messages may be shown for the older kernel, similar to the following:
+The KVM modules from the kmod-kvm package on do not support kernels prior to version 2.6.18-203.el5. If kmod-kvm is updated and an older kernel is kept installed, "unresolved symbols" messages may be shown for the older kernel, similar to the following:
-WARNING: /lib/modules/2.6.18-194.el5/weak-updates/kmod-kvm/ksm.ko needs unknown symbol kvm_ksm_spte_count
+WARNING: /lib/modules/2.6.18-194.el5/weak-updates/kmod-kvm/ksm.ko needs unknown symbol kvm_ksm_spte_count-
-This shouldn't affect the ability to load the KVM modules when running an up-to-date kernel version.

Note You need to log in before you can comment on or make changes to this bug.