Bug 509366 - pnmtofiasco and fiascotopnm fail on s390x and ppc
pnmtofiasco and fiascotopnm fail on s390x and ppc
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: netpbm (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Jindrich Novy
Petr Šplíchal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-02 09:45 EDT by Petr Šplíchal
Modified: 2016-05-31 21:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 01:47:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Šplíchal 2009-07-02 09:45:18 EDT
Description of problem:

Conversion between PNM and FIASCO image formats does not work well
on s390x and ppc architectures.

Version-Release number of selected component (if applicable):
netpbm-progs-10.35.58-8.el5.s390x
netpbm-10.35.58-8.el5.s390

How reproducible:
Always

Steps to Reproduce:
ppmwheel 100 | pnmquant 16 > test.ppm
ppmtopgm test.ppm > test.pgm
pgmtopbm test.pgm > test.pbm

pnmtofiasco <test.ppm >from-ppm.fiasco
pnmtofiasco <test.pgm >from-pgm.fiasco
pnmtofiasco <test.pbm >from-pbm.fiasco

fiascotopnm <from-ppm.fiasco >back.ppm
fiascotopnm <from-pgm.fiasco >back.pgm
fiascotopnm <from-pbm.fiasco >back.pbm

View the images.
  
Actual results:
fiascotopnm: fiascotopnm.c: line 271:
Error: Can't read next bit from bitfile -.
Resulting back* images broken.

Expected results:
No error messages, images converted successfully.
Comment 2 RHEL Product and Program Management 2010-08-09 15:14:53 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2011-05-31 10:31:13 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 errata-xmlrpc 2012-02-21 01:47:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0287.html

Note You need to log in before you can comment on or make changes to this bug.