Bug 509372 - F11 lockup waiting for hardware to initialize
F11 lockup waiting for hardware to initialize
Status: CLOSED DUPLICATE of bug 498457
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-02 10:10 EDT by Luca Giuzzi
Modified: 2009-08-31 09:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-31 09:20:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci (5.98 KB, application/octet-stream)
2009-07-02 10:10 EDT, Luca Giuzzi
no flags Details

  None (edit)
Description Luca Giuzzi 2009-07-02 10:10:35 EDT
Created attachment 350275 [details]
lspci

Description of problem:
 I am unable install F11 on a Fujitsu-Siemens Esprimo P5710.
 Both the DVD install and preupgrade lock-up on 
 "Waiting for Hardware to initialize ..."
 usually without any further message.
 [once an invalid opcode message had been printed on the
 screen afterwards; however, this I cannot reproduce this
 in a reliable way] 
 The keyboard ends up being locked up as well, but there are
 no flashing leds to suggest a kernel panic.

 F10 works sort-of-fine (apart from having to size the memory manually).


Version-Release number of selected component (if applicable):
 Fedora 11

How reproducible:
 Every time an install is attempted.

Steps to Reproduce:
1. Attempt a DVD or preupgrade install
  
Actual results:
 System lock-up

Expected results:
 Anaconda setup screen

Additional info:
 The machine has a shared memory video card; processor is a Pentium-D @3.40 Ghz.
 I include a copy of lspci, in case it is needed.
 The bug seems similar to 471375 (but the network card as well as the product version are different)
Comment 1 Chuck Ebbert 2009-07-02 23:39:05 EDT
Try removing "quiet" and adding "ignore_loglevel" to the boot options to see where it hangs.
Comment 2 Luca Giuzzi 2009-07-03 09:16:50 EDT
Here I go ...

[drm] Initialized drm 1.1.0 20060810
radeon 0000:01:05.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[drm] Detected VRAM RAM=131072K, accessible=131072K, BAR=262144K

This is, unfortunately, a shared memory video card.
Comment 3 Luca Giuzzi 2009-07-03 09:43:54 EDT
Incidentally, I can change the amount of memory allocated to the video card
 to 256M by a setting in the bios. The system still locks up, the only difference
 being the third line which becomes (as expected)

 [drm] Detected VRAM RAM=262144K, accessible=262144K, BAR=262144K
Comment 4 Luca Giuzzi 2009-08-31 09:20:15 EDT
The bug is definitely related to the video card (which is a RC410); I can get anaconda to start with the "nomodeset" option (no luck with X, though). Hence, it appears to be a duplicate of 498457.

*** This bug has been marked as a duplicate of bug 498457 ***

Note You need to log in before you can comment on or make changes to this bug.