Bug 509390 - Nouveau refuses to drive one of my monitors at the maximum resolution
Nouveau refuses to drive one of my monitors at the maximum resolution
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-02 11:06 EDT by Tom Hughes
Modified: 2009-07-03 12:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-03 12:33:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (107.75 KB, text/plain)
2009-07-02 11:07 EDT, Tom Hughes
no flags Details

  None (edit)
Description Tom Hughes 2009-07-02 11:06:59 EDT
Description of problem:

I have two monitors, a 2560x1600 flat panel on DVI-I-0 and a 1600x1200 flat panel on DVI-I-1. The Nvidia binary driver is quite happy to drive them both via the following card:

 01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600 GT (rev a1)

Nouveau refuses to drive the large monitor at full resolution - the mode is rejected:

(II) NOUVEAU(0): Not using mode "2560x1600" (mode clock too high)

Looking at the source I suspect it thinks I only have a single link cable plugged in to that port but I in fact have a dual link cable.

Version-Release number of selected component (if applicable):

xorg-x11-drv-nouveau-0.0.12-40.20090528git0c17b87.fc11.x86_64

How reproducible:

Every time.

Steps to Reproduce:
1. Start X with nouveau as the driver
  
Actual results:

Screen runs at 1280x800.

Expected results:

Screen runs at 2560x1600.

Additional info:

Xorg log attached.
Comment 1 Tom Hughes 2009-07-02 11:07:28 EDT
Created attachment 350294 [details]
Xorg log file
Comment 2 Ben Skeggs 2009-07-02 17:55:05 EDT
The problem is that not all cards are configured at startup to be able to drive a display at those clock speeds.  Your card may be able to, try adding "nouveau.modeset=1 nouveau.duallink=1" to your boot options.
Comment 3 Tom Hughes 2009-07-03 12:33:01 EDT
I am able to get the big monitor to come up at full resolution by doing that, yes.

Things still don't really work because the machine locks up repeatedly. with nouveau reporting timeouts in the kernel log, but that's a different issue.

Note You need to log in before you can comment on or make changes to this bug.