Bug 509393 - Plans for Erlang R13B?
Plans for Erlang R13B?
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: erlang (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: 491165
  Show dependency treegraph
 
Reported: 2009-07-02 11:17 EDT by Hans Ulrich Niedermann
Modified: 2010-03-23 19:25 EDT (History)
4 users (show)

See Also:
Fixed In Version: erlang-R13B-04.1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-23 19:25:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update to R13B03 release (3.95 KB, patch)
2009-12-09 06:40 EST, Hans Ulrich Niedermann
no flags Details | Diff
Update to R13B03 with noarch docs, and xz compression (8.36 KB, text/plain)
2010-01-24 08:47 EST, Hans Ulrich Niedermann
no flags Details

  None (edit)
Description Hans Ulrich Niedermann 2009-07-02 11:17:58 EDT
Are there any plans to update to Erlang R13B some time
in F11? Or will F12 ship with R13B?
Comment 1 Hans Ulrich Niedermann 2009-08-09 08:28:56 EDT
Hello? Anybody there?
Comment 2 Gérard Milmeister 2009-08-10 13:16:16 EDT
I am sorry for taking so long. I am currently taking up the work on Fedora packages that I have been guilty of neglecting :-)
Have you already built R13B?
Comment 3 Gérard Milmeister 2009-08-10 19:24:07 EDT
I built R13B for rawhide.
Could you test it?
If you want I can also built for F11-testing.
Comment 4 Hans Ulrich Niedermann 2009-08-13 16:51:24 EDT
I have been running my own R13B on F11 for several weeks (with the emacs stuff, cf. bug 491165).

Given the number of potentially large changes between R12 and R13 (e.g. unicode handling), I would *NOT* ship R13 as an update on F11. Also, the change from R12 in F11 to R13 in F12 should probably have a place in the F12 release notes.

IIRC, it appeared that at least one erlang based package (IIRC the SDL one) needs rebuilding. But I'd have to recheck that, it has been a few weeks.
Comment 5 Bug Zapper 2009-11-16 05:36:30 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Uwe Kubosch 2009-12-05 21:36:30 EST
We are using RabbitMQ on RHEL5, and we would really benefit from the new garbage collection changes present in R13B3

Please release a package with Erlang R13B3 to EPEL5.  We would be happy to help in testing.
Comment 7 Hans Ulrich Niedermann 2009-12-06 06:30:38 EST
(In reply to comment #6)
> We are using RabbitMQ on RHEL5, and we would really benefit from the new
> garbage collection changes present in R13B3
> 
> Please release a package with Erlang R13B3 to EPEL5.  We would be happy to help
> in testing.  

Going from R12B5 to R13B3 on EPEL5 looks like a very big step. I would want to have a test plan for at least all the other Erlang programs within the distribution for regressions, and probably some Erlang programs outside the distribution as well.
Comment 8 Uwe Kubosch 2009-12-07 08:29:04 EST
I agree that thorough testing is required for a platform package like Erlang.

Please start the testing process by making a package available in updates-testing, without auto-karma so it is not moved to updates until testing is completed.

Postponing the package until a test plan is available seems unnecessary.
Comment 9 Hans Ulrich Niedermann 2009-12-09 06:40:53 EST
Created attachment 377145 [details]
Update to R13B03 release

* Mon Dec  7 2009 Hans Ulrich Niedermann <hun@n-dimensional.de> - R13B-03.1
- Update to R13B03
- Remove patch for OTP-8199 (it is included in R13B03)
Comment 10 Uwe Kubosch 2009-12-11 16:57:34 EST
Have you done a build, yet?
Comment 11 Hans Ulrich Niedermann 2009-12-11 17:24:41 EST
(In reply to comment #10)
> Have you done a build, yet?  

Only local builds on my F11 system, not on koji.

I am not a (co)maintainer of Fedora's erlang package, so I cannot build my own non-scratch Erlang packages on koji, and building scratch packages would require me to upload the humongous .src.rpm file to koji.

I have not locally tried any mock builds for F12/F13 yet, either.
Comment 12 Hans Ulrich Niedermann 2009-12-12 10:29:49 EST
Apparently, you can now (R13B03 and newer) build the docs yourself when xsltproc and fop are installed. I have yet to verify that this works on Fedora, but that might be interesting to get rid of the doc tarballs.
Comment 13 Uwe Kubosch 2010-01-23 19:26:08 EST
I see kkofler has made an Erlang R13B package available for F12.  Could a package for epel5 be made available also, please?
Comment 14 Hans Ulrich Niedermann 2010-01-24 06:25:12 EST
According to my tests, R13B03 does build without problems and with minimal changes to the spec file on F11 and rawhide-of-a-few-weeks-ago.

It is just the other two changes I would like to see in the erlang package which create problems (read: do not work), but those are unrelated: a) Building the docs while building the packages and b) shipping the emacs files in ready-to-use manner.

IMHO, putting R13B03 at least into F13 before all the freezes start would make a lot of sense. Considering that there is a R13B01 in F12, an update to R13B03 for F12 would also not be totally out of this world.
Comment 15 Hans Ulrich Niedermann 2010-01-24 08:47:54 EST
Created attachment 386439 [details]
Update to R13B03 with noarch docs, and xz compression

I have just done a koji scratch build of a R13B03 package:

    http://koji.fedoraproject.org/koji/taskinfo?taskID=1941137

The spec file changelog:

* Sun Jan 24 2010 Hans Ulrich Niedermann <hun@n-dimensional.de> - R13B-03.4
- Make doc subpackage nocarch on F-11 and newer
- Remove patch for OTP-8199 (it is intetrated into R13B03)
- Update to R13B03
- Uncompress doc tarballs in any format

NOTE: I took the liberty to locally change the tarball compression from gzip to xz for this scratch build to significantly reduce the .src.rpm upload time. That would not find its way into a proper Fedora package, obviously.

NOTE2: Changing the doc subpackage to use noarch makes sense, as the contents are noarch and the rpm file consumes a significant amount of space at 13MB.
Comment 16 Uwe Kubosch 2010-02-09 19:20:49 EST
We have now compiled Erlang R13B03 ourselves and are running it in production with no problems and a major improvement on memory usage.  Our only Erlang application is RabbitMQ.

An RPM for EPEL-5 would be nice, but we don't care that much anymore.
Comment 17 Peter Lemenkov 2010-02-25 09:30:21 EST
Just FYI - I'm preparing package for R13B-04.
Comment 18 Jeffrey C. Ollie 2010-03-13 22:46:39 EST
What's the status of R13B-04?  It would be nice to have this in the F13 release.
Comment 19 Peter Lemenkov 2010-03-14 11:59:53 EDT
Folks, here is a short status-report regarding my effords on making erlang packaging and using in Fedora easy:

* I almost finished ripping off some rarely used (or developer's only) libraries. See #564018 for further details.
* I rebased all patches, we used previously, on top of R13B-04. See http://github.com/lemenkov/otp/commits/fedora - actually, only two patches are still required.
* I updated package to R13B-04

See preliminary spec-file:

http://peter.fedorapeople.org/erlang.spec

I plan to build an push R13B-04 w/o modularization, but with removed useless sources next monday (15-03-2010) and will continue modularization efforts after that.

Just FYI - I started working on erlang-rpm-macros package, which will be an add-on for rpm-build - it will contain erlang-find-requires and erlang-find-provides scripts for automatic erlang Provides/Requires providing as well as useful handy macros for simplifying packaging. I plan to package it as soon as it would be ready and I plan to merge it into upstream rpm too.

http://peter.fedorapeople.org/erlang.spec
Comment 20 Peter Lemenkov 2010-03-15 07:00:58 EDT
Here is the status report:

* R13B-04 was built for rawhide.
* R13B-04 was NOT built for F-13 due to broken dependencies from gstreamer apps while rebuilding. Hope this will be fixed soon.

* I also considering updating F-12 branch up to R13B-04. From what I see so far this won't break other's stuff.
* Here is a scratchbuild for F-12

http://koji.fedoraproject.org/koji/taskinfo?taskID=2052699
Comment 21 Fedora Update System 2010-03-16 03:35:09 EDT
erlang-R13B-04.1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/erlang-R13B-04.1.fc13
Comment 22 Peter Lemenkov 2010-03-16 03:40:27 EDT
Another status report - R13B-04 was built for F-13. RPM for F-12 will be built very soon (in a couple of days, I hope).

Please, note that F-11 will NOT be updated (as well as EPEL4,5 branches).
Comment 23 Fedora Update System 2010-03-17 12:02:01 EDT
erlang-R13B-04.1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/erlang-R13B-04.1.fc12
Comment 24 Peter Lemenkov 2010-03-17 12:07:18 EDT
Folks, I would like to emphasize, that this build (namely, R13B-04.1), adds *another* one dependency - wxWidgets. In fact, previous builds doesnt require it because they were broken.
Comment 25 Fedora Update System 2010-03-19 23:36:49 EDT
erlang-R13B-04.1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update erlang'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/erlang-R13B-04.1.fc12
Comment 26 Fedora Update System 2010-03-23 19:18:37 EDT
erlang-R13B-04.1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Fedora Update System 2010-03-23 19:25:14 EDT
erlang-R13B-04.1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.