Bug 509430 - Kickstart config file for RHEL 2.1 kickstarts not downloaded by anaconda on Satellite 530
Kickstart config file for RHEL 2.1 kickstarts not downloaded by anaconda on S...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Steve Salevan
:
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-07-02 14:13 EDT by Steve Salevan
Modified: 2009-09-10 15:27 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:27:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Salevan 2009-07-02 14:13:37 EDT
Description of problem:
If a user attempts to kickstart a machine to RHEL 2.1 using Satellite 530, the kickstart config file generated by Cobbler will not be downloaded by the RHEL 2.1's anaconda.

Version-Release number of selected component (if applicable):
530, 6/25 build

How reproducible:
Always

Steps to Reproduce:
1. Attempt to kickstart a machine to RHEL 2.1 using Satellite 530
  
Actual results:
RHEL 2.1's anaconda attempts to access the config file by looking in the /tmp/ directory of its initrd, discovering that this file is not present

Expected results:
RHEL 2.1's anaconda discovers the kickstart file

Additional info:
Comment 5 Clifford Perry 2009-07-02 16:52:32 EDT
Approved - seems like still under investigation. Is subject to being punted off release if needed.
Comment 6 Justin Sherrill 2009-07-09 14:05:03 EDT
So I was able to reproduce this, but I believe it's a problem with 2.1 on that particular hardware.  If you look in the other VT's, (alt-F2, alt-F3) you'll see it complaining about 'device not found' for eth0 as the dhcp fails.  

I'm going to move this to on_qa, and if we can't reproduce on other hardware, it's not a bug.
Comment 7 Steve Salevan 2009-07-13 12:43:18 EDT
Again, it seems that this bug arose from an eccentricity of 2.1 with that particular piece of hardware, and I've been able to successfully reprovision 2.1 with other hardware, so I'm moving this bug to VERIFIED, tested on 7/7 build.
Comment 8 wes hayutin 2009-07-22 17:07:32 EDT
please test w/ fjs clients
Comment 9 Steve Salevan 2009-08-11 11:16:34 EDT
FAILS_QA on a multitude of different hardware, as I'm no longer able to successfully provision 2.1 and am seeing the issue I originally reported across the Stage environment.  Tested on 7/24 build.
Comment 10 Justin Sherrill 2009-08-11 18:12:23 EDT
Steve, so what sort of error are you currently seeing?  

If you're still seeing 'cannot download /tmp/ks.cfg' then that is simply because 2.1 isn't supporting the network hardware on that box.
Comment 11 Justin Sherrill 2009-08-12 18:32:50 EDT
so while testing 2.1 kickstarting again, i found another bug.  While viewing any 2.1 system you will get an ISE if you click the provisioning tab.  The cause is that 2.1 does not upload the network interface information which that page was now depending on.  

VADER: 94ce506
master: 6233af8


So with this fix I am fixing that issue.  However, i encountered an issue several times on 2 different pieces of hardware (one which did not exhibit on this problem a month ago).  During a kickstart of 2.1  you'll get a traceback during the post install configuration.  When the system reboots you'll be left at a grub prompt.  

Cliff said that this is ok because we are mostly concerned with going from 2.1 to another version (3, 4 or 5).  So in your testing Steve, lets just test 2.1 -> something else.  I tested 2.1 to RHEL 5.2 and it worked just fine.  If you'd like a 2.1 box to use just let me know.

-justin
Comment 12 Steve Salevan 2009-08-17 16:02:55 EDT
RELEASE_PENDING from latest Stage build.

As per cperry and mmccune's decision, we no longer support kickstarting to 2.1 via Satellite 530, though we do support kickstarting from 2.1 to newer versions of RHEL.
Comment 13 Brandon Perkins 2009-09-10 15:27:11 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.