Bug 509455 - GTKPOD unable to open M4A files
GTKPOD unable to open M4A files
Status: CLOSED DUPLICATE of bug 507302
Product: Fedora
Classification: Fedora
Component: libmp4v2 (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-02 17:06 EDT by Phip
Modified: 2009-08-02 15:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-02 15:35:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A file which gtkpod cannot open (293.35 KB, application/octet-stream)
2009-07-02 17:06 EDT, Phip
no flags Details

  None (edit)
Description Phip 2009-07-02 17:06:24 EDT
Created attachment 350349 [details]
A file which gtkpod cannot open

Description of problem:
Gtkpod gives an error when trying to add .m4a files that it previously accepted.

Version-Release number of selected component (if applicable):
0.99.14-2.fc11

How reproducible:
Always

Steps to Reproduce:
1. In gtkpod with an ipod loaded, click 'add files' or 'add folder'
2. Make selection to include .m4a files
  
Actual results:
Error dialog opens, with two messages:
- Could not open '/path/to/file.m4a' for reading, or file is not an mp4 file.
- The following track could not be processed (filetype is known but analysis failed): '/path/to/file.m4a'

Expected results:
Successfully adding the file to my ipod as it did in the (uncertain but not-too-distant) past.

Additional info:
The files in question were encoded by iTunes 7 for Mac OS and have worked previously with gtkpod and continue to be playable. A sample can be uploaded if needed
Comment 1 Todd Zullinger 2009-07-02 17:54:20 EDT
I helped someone in #gtkpod debug this the other day.  It seems that the libmp4v2 in F-11 cannot parse most .mp4/.m4a files.  I used mp4info on a file that gtkpod failed to read and it failed to read it as well.  The same files parse fine with gtkpod and mp4info on F-10.
Comment 2 Phip 2009-08-02 15:16:36 EDT
Any ideas what changed in libmp4v2? It seems like a pretty big problem for libmp4v2 to not be able to read mp4 files...
Comment 3 Todd Zullinger 2009-08-02 15:35:41 EDT
I think the problem was due to a bad libmp4v2 build.  It might have been built at a time when gcc or some other component of the tree was a bit flaky.  There is an updated libmp4v2 available (libmp4v2-1.5.0.1-9.fc11) which fixes this issue.  This was apparently reported in bug #507302.

I've verified that the update fixes mp4info.  I did not test it with gtkpod, but I fully expect it to work.  If it does not, please reopen this bug.

*** This bug has been marked as a duplicate of bug 507302 ***

Note You need to log in before you can comment on or make changes to this bug.