Bug 509465 - i915 bug, frequent X freezes on Thinkpad x200s
i915 bug, frequent X freezes on Thinkpad x200s
Status: CLOSED DUPLICATE of bug 509519
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
11
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-02 20:08 EDT by Andrei Gaponenko
Modified: 2009-08-02 12:51 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-02 12:51:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of the crashed X server (34.79 KB, text/plain)
2009-07-02 20:09 EDT, Andrei Gaponenko
no flags Details
output of lspci -vvv (21.68 KB, text/plain)
2009-07-02 20:10 EDT, Andrei Gaponenko
no flags Details

  None (edit)
Description Andrei Gaponenko 2009-07-02 20:08:27 EDT
Hello,

After installing today's updates to Fedora 11, X froze twice in an
hour. Using KDE, with desktop effects enabled.  I've been using the
system for a few weeks, this problem is new.  A complete list of
updated RPMs is below.  (mesa-dri-drivers-7.6-0.1.fc11.x86_64 is the
likely culprit?)

After the second freeze I used ssh from another machine to get on the
laptop, and found that the [X] process was in the "Ds+" state, taking 
VMem=0kb, RSS=0kb, and being non-killable with either 15 or 9.
/var/log/messages had the following backtrace:


Jul  2 16:17:38 x200s kernel: ------------[ cut here ]------------
Jul  2 16:17:38 x200s kernel: kernel BUG at drivers/gpu/drm/i915/i915_gem.c:2136!
Jul  2 16:17:38 x200s kernel: invalid opcode: 0000 [#1] SMP
Jul  2 16:17:38 x200s kernel: last sysfs file: /sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0/rfkill/rfkill1/state
Jul  2 16:17:38 x200s kernel: CPU 0
Jul  2 16:17:38 x200s kernel: Modules linked in: fuse sco bridge stp llc bnep l2cap bluetooth sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq freq_table ext2 dm_multipath uinput snd_hda_codec_conexant arc4 snd_hda_intel ecb snd_hda_codec snd_hwdep iwlagn iwlcore snd_pcm snd_timer lib80211 s
nd mac80211 soundcore e1000e thinkpad_acpi i2c_i801 wmi usb_storage snd_page_alloc cfg80211 pcspkr joydev iTCO_wdt hwmon iTCO_vendor_support i915 drm i2c_algo_bit i2c_core video output [last unloaded: microcode]
Jul  2 16:17:38 x200s kernel: Pid: 2095, comm: X Not tainted 2.6.29.5-191.fc11.x86_64 #1 74663JU
Jul  2 16:17:38 x200s kernel: RIP: 0010:[<ffffffffa005f3d2>]  [<ffffffffa005f3d2>] i915_gem_object_get_fence_reg+0x221/0x61e [i915]
Jul  2 16:17:38 x200s kernel: RSP: 0000:ffff880139503be8  EFLAGS: 00013202
Jul  2 16:17:38 x200s kernel: RAX: 0000000000041858 RBX: ffff880010823780 RCX: 0000000000000010
Jul  2 16:17:38 x200s kernel: RDX: 0000000000002a42 RSI: 0000000000041858 RDI: ffff8800098f3180
Jul  2 16:17:38 x200s kernel: RBP: ffff880139503c28 R08: 0000000000000003 R09: ffff88013a40e1e8
Jul  2 16:17:38 x200s kernel: R10: 6db6db6db6db6db7 R11: 00001e0000000000 R12: ffff8800098f33c0
Jul  2 16:17:38 x200s kernel: R13: ffff88013a40e000 R14: ffff880010823900 R15: ffff88013a40d000
Jul  2 16:17:38 x200s kernel: FS:  00007f2d4b9597b0(0000) GS:ffffffff817b7000(0000) knlGS:0000000000000000
Jul  2 16:17:38 x200s kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Jul  2 16:17:38 x200s kernel: CR2: 00007f2d443cd000 CR3: 0000000138c15000 CR4: 00000000000006e0
Jul  2 16:17:38 x200s kernel: DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Jul  2 16:17:38 x200s kernel: DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Jul  2 16:17:38 x200s kernel: Process X (pid: 2095, threadinfo ffff880139502000, task ffff88013900dc00)
Jul  2 16:17:38 x200s kernel: Stack:
Jul  2 16:17:38 x200s kernel: ffff880139503c28 ffff88013a40e1e8 ffff88013a40d020 ffff880010823900
Jul  2 16:17:38 x200s kernel: ffff88013a40d020 ffff880010823780 ffff880013b564d0 ffff880139503ce8
Jul  2 16:17:38 x200s kernel: ffff880139503c98 ffffffffa00610d3 ffff880139503c48 00007f2d443cd000
Jul  2 16:17:38 x200s kernel: Call Trace:
Jul  2 16:17:38 x200s kernel: [<ffffffffa00610d3>] i915_gem_fault+0xc1/0x136 [i915]
Jul  2 16:17:38 x200s kernel: [<ffffffffa005dbaf>] ? drm_free_large+0x2b/0x34 [i915]
Jul  2 16:17:38 x200s kernel: [<ffffffff810b213f>] __do_fault+0x55/0x3d5
Jul  2 16:17:38 x200s kernel: [<ffffffffa002bb3b>] ? drm_mm_put_block+0xa2/0xba [drm]
Jul  2 16:17:38 x200s kernel: [<ffffffff810b4475>] handle_mm_fault+0x349/0x7c5
Jul  2 16:17:38 x200s kernel: [<ffffffff813ae615>] do_page_fault+0x5b5/0x9e9
Jul  2 16:17:38 x200s kernel: [<ffffffff813ac01a>] ? unlock_kernel+0x2f/0x32
Jul  2 16:17:38 x200s kernel: [<ffffffff810e0e27>] ? vfs_ioctl+0x76/0x87
Jul  2 16:17:38 x200s kernel: [<ffffffff810e12bb>] ? do_vfs_ioctl+0x462/0x4a3
Jul  2 16:17:38 x200s kernel: [<ffffffff813abab5>] ? trace_hardirqs_off_thunk+0x3a/0x6c
Jul  2 16:17:38 x200s kernel: [<ffffffff813ac175>] page_fault+0x25/0x30
Jul  2 16:17:38 x200s kernel: Code: ff e8 35 e9 ff ff 85 c0 0f 84 b3 fe ff ff e9 06 04 00 00 41 83 7c 24 20 00 75 10 48 8b 55 c8 48 8b 02 f7 40 70 be ff ff ff 74 04 <0f> 0b eb fe 49 8b bf 38 01 00 00 48 8b 70 38 48 85 ff 74 1a 48
Jul  2 16:17:38 x200s kernel: RIP  [<ffffffffa005f3d2>] i915_gem_object_get_fence_reg+0x221/0x61e [i915]
Jul  2 16:17:38 x200s kernel: RSP <ffff880139503be8>
Jul  2 16:17:38 x200s kernel: ---[ end trace 1bf08f4a0c2ef9a6 ]---



This is the full list of today's RPM updates, I did not see this
problem before those updates


Jul 02 14:47:14 Updated: nspr-4.8-1.fc11.x86_64
Jul 02 14:47:19 Updated: xulrunner-1.9.1-1.fc11.x86_64
Jul 02 14:47:20 Updated: strigi-libs-0.6.5-2.fc11.x86_64
Jul 02 14:47:21 Updated: libxcb-1.2-4.fc11.x86_64
Jul 02 14:47:22 Updated: xulrunner-python-1.9.1-1.fc11.x86_64
Jul 02 14:47:24 Updated: mesa-dri-drivers-7.6-0.1.fc11.x86_64
Jul 02 14:47:24 Updated: mesa-libGL-7.6-0.1.fc11.x86_64
Jul 02 14:47:25 Updated: mesa-libGLU-7.6-0.1.fc11.x86_64
Jul 02 14:47:26 Updated: numactl-2.0.3-1.fc11.x86_64
Jul 02 14:47:33 Updated: perl-Tk-804.028-9.fc11.x86_64
Jul 02 14:47:34 Updated: glx-utils-7.6-0.1.fc11.x86_64
Jul 02 14:47:35 Updated: hulahop-0.4.9-5.fc11.x86_64
Jul 02 14:47:55 Updated: yelp-2.26.0-4.fc11.x86_64
Jul 02 14:48:03 Updated: scribus-1.3.5-0.13.rc2.fc11.x86_64
Jul 02 14:48:04 Updated: gdb-6.8.50.20090302-32.fc11.x86_64
Jul 02 14:48:06 Updated: 1:cpuspeed-1.5-10.fc11.x86_64
Jul 02 14:48:07 Updated: mesa-dri-drivers-7.6-0.1.fc11.i586
Jul 02 14:48:08 Updated: mesa-libGL-7.6-0.1.fc11.i586
Jul 02 14:48:09 Updated: mesa-libGLU-7.6-0.1.fc11.i586
Jul 02 14:48:10 Updated: nspr-4.8-1.fc11.i586
Jul 02 14:48:11 Updated: libxcb-1.2-4.fc11.i586
Jul 02 14:48:14 Updated: mesa-libGL-devel-7.6-0.1.fc11.x86_64
Jul 02 14:48:15 Updated: nspr-devel-4.8-1.fc11.x86_64
Jul 02 14:48:16 Updated: gnome-python2-extras-2.25.3-4.fc11.x86_64
Jul 02 14:48:17 Updated: libxcb-devel-1.2-4.fc11.x86_64
Jul 02 14:48:18 Updated: gnome-python2-libegg-2.25.3-4.fc11.x86_64
Jul 02 14:48:19 Updated: gnome-python2-gtkhtml2-2.25.3-4.fc11.x86_64
Jul 02 14:48:33 Updated: xulrunner-devel-1.9.1-1.fc11.x86_64
Jul 02 14:48:34 Updated: mesa-libGLU-devel-7.6-0.1.fc11.x86_64
Jul 02 14:48:38 Updated: firefox-3.5-1.fc11.x86_64
Jul 02 14:48:39 Updated: redhat-rpm-config-9.0.3-9.fc11.noarch
Jul 02 14:48:41 Updated: kdebase-runtime-libs-4.2.4-2.fc11.x86_64
Jul 02 14:48:47 Updated: kdebase-runtime-4.2.4-2.fc11.x86_64


lspci -vvv output is attached.  Also Xorg.0.log from the crash.

Please let me know what I can do to help resolve the problem.

Regareds,
Andrei
Comment 1 Andrei Gaponenko 2009-07-02 20:09:47 EDT
Created attachment 350361 [details]
log of the crashed X server
Comment 2 Andrei Gaponenko 2009-07-02 20:10:29 EDT
Created attachment 350362 [details]
output of lspci -vvv
Comment 3 Kornienko Sergey 2009-07-06 06:44:33 EDT
Hello all !
After upgrade mesa packages I have simular problems, sometimes X-server freeze with one beep, always, if I use KDE desktop effects and when I want switch between windows, but I can login in my system remotely, by ssh. In Xorg.log nothing strange, there are no errors, the messages from server, a typical

I'm use Fedora 11 x86_64
Hardware is Samsung Q45, Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller

DE is KDE, effects is on.

[vinni@lair ~]$ uname -a
Linux lair 2.6.29.5-191.fc11.x86_64 #1 SMP Tue Jun 16 23:23:21 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

[vinni@lair ~]$ lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8039 PCI-E Fast Ethernet Controller (rev 15)
04:09.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b4)
04:09.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 09)
04:09.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 18)
04:09.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 09)
04:09.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 04)

First updated packages: 
Jul 03 10:35:06 Updated: mesa-dri-drivers-7.6-0.1.fc11.x86_64
Jul 03 10:35:06 Updated: mesa-libGL-7.6-0.1.fc11.x86_64
Jul 03 10:35:07 Updated: mesa-libGLU-7.6-0.1.fc11.x86_64
Jul 03 10:40:53 Updated: mesa-dri-drivers-7.6-0.1.fc11.i586
Jul 03 10:40:54 Updated: mesa-libGL-7.6-0.1.fc11.i586
Jul 03 10:40:55 Updated: mesa-libGLU-7.6-0.1.fc11.i586

Downgrade to:
Jul 06 12:53:57 Installed: mesa-dri-drivers-7.5-0.14.fc11.x86_64
Jul 06 12:53:58 Installed: mesa-libGL-7.5-0.14.fc11.x86_64
Jul 06 12:53:59 Installed: mesa-dri-drivers-7.5-0.14.fc11.i586
Jul 06 12:54:00 Installed: mesa-libGLU-7.5-0.14.fc11.x86_64
Jul 06 12:54:01 Installed: mesa-libGL-7.5-0.14.fc11.i586
Jul 06 12:54:01 Installed: mesa-libGLU-7.5-0.14.fc11.i586

After downgrade and reboot this help me ! Now I will wait for patches mesa packages :)
Comment 4 Thomas Spura 2009-07-11 13:01:04 EDT
The similar problems from Kornienko Sergey should be bug #509519
This one could, too.
Comment 5 Thomas Janssen 2009-08-02 12:51:50 EDT

*** This bug has been marked as a duplicate of bug 509519 ***

Note You need to log in before you can comment on or make changes to this bug.