Bug 509466 - httpd start/stop doesn't work
httpd start/stop doesn't work
Status: CLOSED DUPLICATE of bug 508170
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-02 20:26 EDT by Dennis Jacobfeuerborn
Modified: 2009-08-18 07:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-18 07:52:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Jacobfeuerborn 2009-07-02 20:26:46 EDT
After enabling the httpd service and booting httpd is running correctly but cannot be shutdown using the initscript. Shutting down the machine results in a "shutting down httpd: FAILED".

The reason seems to be that the initscript specifies the pidfile as "/var/run/httpd/httpd.pid" yet after the sevice is started the actual pidfile used is "/var/run/httpd.pid". As a result the shutdown of the service files because the wrong pidfile gets checked.

Changing the pidfile variable in the initscript to "/var/run/httpd.pid" makes the symptoms go away but the real problem seems to be that the initscript/httpd doesn't create the right pidfile to begin with.
Comment 1 Joe Orton 2009-08-18 07:52:54 EDT

*** This bug has been marked as a duplicate of bug 508170 ***

Note You need to log in before you can comment on or make changes to this bug.