Bug 509470 - F11: sedispatch: AVC Message for setroubleshoot, dropping message
F11: sedispatch: AVC Message for setroubleshoot, dropping message
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-02 20:55 EDT by dedded
Modified: 2009-07-06 16:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-06 16:46:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dedded 2009-07-02 20:55:15 EDT
Description of problem:

I get the following message 6-12 times an hour in my terminal windows.  I'm not aware of any ill effects other than the distraction of the messages, but what a distraction!  It's very frequent and irritating.  The message always appears in pairs.

   Message from syslogd@dkc2 at Jul  2 20:33:33 ...
    sedispatch: AVC Message for setroubleshoot, dropping message

   Message from syslogd@dkc2 at Jul  2 20:33:33 ...
    sedispatch: AVC Message for setroubleshoot, dropping message

I found the following while trying to google the problem:
   https://fedorahosted.org/setroubleshoot/changeset/1346:283bba04161f


Version-Release number of selected component (if applicable):

2.1.14


How reproducible:

Open a terminal window, then wait for the message.
Comment 1 Daniel Walsh 2009-07-06 14:08:03 EDT
These are caused by avc messages about setroubleshoot. 
Could you look for setroubleshootd_t messages in your /var/log/audit/audit.log
Comment 2 dedded 2009-07-06 14:36:52 EDT
There are a bunch that look like this:

type=AVC msg=audit(1244898663.184:43294): avc:  denied  { read } for  pid=3098 comm="setroubleshootd" name="site-python-f11" dev=sda7 ino=7296490 scontext=system_u:system_r:setroubleshootd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:default_t:s0 tclass=lnk_file
type=SYSCALL msg=audit(1244898663.184:43294): arch=c000003e syscall=4 success=no exit=-13 a0=1a4f9f0 a1=7fff2f327e40 a2=7fff2f327e40 a3=20 items=0 ppid=3097 pid=3098 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="setroubleshootd" exe="/usr/bin/python" subj=system_u:system_r:setroubleshootd_t:s0-s0:c0.c1023 key=(null)


All seem to be the type=AVC/type=SYSCALL pair.

And all the AVC messages mention "site-python-f11".  Which is mine.  Is this pilot error on my part?
Comment 3 Daniel Walsh 2009-07-06 15:36:28 EDT
Is this a separate directory under /?

Or is it under /usr somewhere?  If under /usr run restorecon -R -v on the directory.


If this is under /  We need to label it as usr_t.
Comment 4 dedded 2009-07-06 16:19:39 EDT
Yes, it's on another partition's filesystem.

Labeling it usr_t.

Sorry for the trouble, and thanks for the help.

Note You need to log in before you can comment on or make changes to this bug.