Bug 509493 - lm_sensors unable to load module it87
lm_sensors unable to load module it87
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lm_sensors (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-03 00:45 EDT by Mohammed Arafa
Modified: 2015-03-04 20:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-04 04:59:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Arafa 2009-07-03 00:45:48 EDT
Description of problem:
i ran sensors-detect which told me i had to change /etc/sysconfig/lm_sensors. i let it do the change then it told me it couldnt find the sensor it had just found.

ran this like 3 times

Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1.run sensors-detect
2.
3.
  
Actual results:
not working

Expected results:
it just works


Additional info:
Now follows a summary of the probes I have just done.
Just press ENTER to continue:

Driver `it87':
  * ISA bus, address 0x290
    Chip `ITE IT8712F Super IO Sensors' (confidence: 9)

Do you want to overwrite /etc/sysconfig/lm_sensors? (YES/no):
Starting lm_sensors: loading module it87 No sensors found!
Make sure you loaded all the kernel drivers you need.
Try sensors-detect to find out which these are.
                                                           [FAILED]
Unloading i2c-dev... OK
Comment 1 Hans de Goede 2009-07-03 02:06:16 EDT
What are the last few lines of the output of dmesg after running sensors-detect ?

Are you using updates testing ? If you are then chances are that you are hitting
this issue:
http://hansdegoede.livejournal.com/7932.html

If you are not using updates-testing chances are your kernel is too old, try:
yum update --enablerepo=updates-testing

Eitherway the output of dmesg after running sensors-detect should help to determine the cause of this.
Comment 2 Mohammed Arafa 2009-07-03 18:24:07 EDT
last few lines of dmesg:

i2c /dev entries driver
it87: Found IT8712F chip at 0x290, revision 6
ACPI: I/O resource it87 [0x295-0x296] conflicts with ACPI region IP__ [0x295-0x296]
ACPI: Device needs an ACPI driver

updates testing: no

kernel too old:
2.6.29.5-191.fc11.x86_64 #1 SMP Tue Jun 16 23:23:21 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
Comment 3 Mohammed Arafa 2009-07-04 01:49:33 EDT
hi
i checked the link you posted and yes it looks like to be one and the same. so how do i fix this on my machine?
Comment 4 Hans de Goede 2009-07-04 04:59:48 EDT
I asked about the old kernel because you indicated F-10 as version. As for how to fix this, the blog post I linked to gives a workaround (which can potentially be dangerous!). This is not a bug, you BIOS claims the IO resources used by the it87, so the native Linux driver cannot load.
Comment 5 Mohammed Arafa 2009-07-04 10:11:14 EDT
first of all i m embarrassed if i had indicated f10.

secondly, lm_sensors was working in f10 but not f11. and no i dont want to do the workaround either.

in any case, the issue is now like beating a dead dog.

so thanks

Note You need to log in before you can comment on or make changes to this bug.