Bug 509511 - KRunner crashes
KRunner crashes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-03 03:56 EDT by Christopher Grebs
Modified: 2009-07-03 06:50 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-03 04:00:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Grebs 2009-07-03 03:56:33 EDT
Description of problem:

KRunner crashes on previewing the available commands.


Version-Release number of selected component (if applicable):

krunner --version
Qt: 4.5.2
KDE: 4.2.95 (KDE 4.2.95 (KDE 4.3 RC1))
Run Command Interface: 0.1

How reproducible:

Start KRunner, hit alt+f2 and enter a command you like (I use “Konsole”, this works perfektly not ;)) and wait one second. Then it crashes.


Steps to Reproduce:
1. Run KRunner (or your KDE-Session)
2. Hit alt+f2
3. Enter some command (e.g Konsole)
  
Actual results:

Crash with the following output:

krunner: symbol lookup error: /usr/lib64/libnepomukquery.so.4: undefined symbol: _ZN7Soprano4NodeC1ERKNS_12LiteralValueE


Expected results:

A running KRunner

Additional info:

Since this is my very first reported bug, tell me if you need more information and how I can apply them. Thanks!
Comment 1 Christopher Grebs 2009-07-03 04:00:32 EDT
Whoops, sorry for all the mail spam, what ever. Just noted that I needed to upgrade the package `soprano`. Now everything works fine.

Regards,
Christopher.
Comment 2 Rex Dieter 2009-07-03 06:50:33 EDT
For posterity, to help avoid similar situations, modified kdelibs:

%changelog
* Fri Jul 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.95-2
- up min versions, phonon, strigi, soprano (#509511)

Note You need to log in before you can comment on or make changes to this bug.