Bug 509522 - Upgrade from RHN Proxy 5.2 to 5.3 fails with spacewalk-proxy-installer conflicts with rhns-proxy-tools
Upgrade from RHN Proxy 5.2 to 5.3 fails with spacewalk-proxy-installer confli...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Miroslav Suchý
Jeff Browning
:
Depends On:
Blocks: 456999
  Show dependency treegraph
 
Reported: 2009-07-03 05:33 EDT by Jan Pazdziora
Modified: 2009-09-10 10:39 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 10:39:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2009-07-03 05:33:31 EDT
Description of problem:

So, I have RHN Proxy 5.2.0 installed and I got the idea of upgrading it to RHN Proxy 5.3.0. I thought I'd use the new configure-proxy.sh command line installer/setuper. So I tried to install the proxy-installer package but I got

Error: spacewalk-proxy-installer conflicts with rhns-proxy-tools

Version-Release number of selected component (if applicable):

RHN Proxy 5.2.0 -> RHN Proxy 5.3.0

How reproducible:

Deterministic.

Steps to Reproduce:
1. Have RHN Proxy 5.2.0.
2. Try to install the spacewalk-proxy-installer package from RHN Tools, to upgrade the proxy to 5.3.0.
  
Actual results:

# yum install spacewalk-proxy-installer
Loaded plugins: rhnplugin, security
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package spacewalk-proxy-installer.noarch 0:0.5.25-13.el5sat set to be updated
--> Processing Dependency: rhncfg-management for package: spacewalk-proxy-installer
--> Processing Dependency: libxslt for package: spacewalk-proxy-installer
--> Running transaction check
---> Package rhncfg-management.noarch 0:5.9.5-3.el5sat set to be updated
---> Package libxslt.x86_64 0:1.1.17-2.el5_2.2 set to be updated
--> Processing Conflict: spacewalk-proxy-installer conflicts rhns-proxy-tools < 5.3.0
--> Finished Dependency Resolution
spacewalk-proxy-installer-0.5.25-13.el5sat.noarch from rhn-tools-rhel-x86_64-server-5 has depsolving problems
  --> spacewalk-proxy-installer conflicts with rhns-proxy-tools
Error: spacewalk-proxy-installer conflicts with rhns-proxy-tools

Expected results:

Clean install.

Additional info:
Comment 1 Miroslav Suchý 2009-07-03 05:42:42 EDT
Commited as db70c434982f41e8d7f2209b0202f36c631a6f2c

Test plan:
- test steps to reproduce
- also pickup some older proxy (for example 5.1), subscribe it to rhn-tools channel and run "up2date -u" and make sure it proceed and *did not* install spacewalk-proxy-installer (possible regression of 470381)
Comment 2 Miroslav Suchý 2009-07-08 09:04:11 EDT
ISO 20090707.0
Mass moving to ON_QA
Comment 3 Jeff Browning 2009-07-23 10:08:54 EDT
Running Transaction
  Installing     : libxslt                                           [1/2] 
  Installing     : spacewalk-proxy-installer                         [2/2] 

Installed: spacewalk-proxy-installer.noarch 0:0.5.25-17.el5sat
Dependency Installed: libxslt.i386 0:1.1.17-2.el5_2.2
Complete!


Verified
Comment 4 Milan Zazrivec 2009-08-10 07:39:29 EDT
Verified in stage -> RELEASE_PENDING
Comment 5 Brandon Perkins 2009-09-10 10:39:25 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.