Bug 509528 - (f11intel-mes) The newly updated mesa 7.6-0.1 breaks many 3D programs with Intel grphics
The newly updated mesa 7.6-0.1 breaks many 3D programs with Intel grphics
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 510161 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-03 06:18 EDT by Howard Ning
Modified: 2009-11-12 07:54 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 12:40:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot Destkop Effects active with mesa 7.6-0.1 in Intel GMA 4500MHD (94.30 KB, image/jpeg)
2009-08-16 13:12 EDT, Ricardo Schmidt
no flags Details

  None (edit)
Description Howard Ning 2009-07-03 06:18:58 EDT
Description of problem:
Today, I do a yum update and the mesa bump to the version 7.6-0.1 like this:
# yum update
Updating : mesa-dri-drivers-7.6-0.1.fc11.x86_64 1/20
Updating : mesa-libGL-7.6-0.1.fc11.x86_64 2/20
Updating : mesa-libGLU-7.6-0.1.fc11.x86_64 3/20
Updating : mesa-dri-drivers-7.6-0.1.fc11.i586 4/20
Updating : mesa-libGL-devel-7.6-0.1.fc11.x86_64 5/20
Updating : mesa-libGL-7.6-0.1.fc11.i586 6/20
Updating : mesa-libGLU-7.6-0.1.fc11.i586 7/20
Updating : mesa-libGL-devel-7.6-0.1.fc11.i586 8/20
Updating : mesa-libGLU-devel-7.6-0.1.fc11.i586 9/20
Updating : mesa-libGLU-devel-7.6-0.1.fc11.x86_64 10/20

Many 3D program stops working.
xmoto will halt at start.
in Nexuiz, you will not see the weapons and opponents seems semi-transparent and many strange graphics as well.

Downgrading to 7.5 will solve the problem.

My graphic card is Intel GMA 4500 MHD. 
Also I get a kernel panic about the dri driver.

Version-Release number of selected component (if applicable):
7.6-0.1

How reproducible:
Upgrade, run 3D programs like xmoto and nexuiz

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Strange graphics or crash

Expected results:
run as normal.

Additional info:
Comment 1 Bojan Smojver 2009-07-03 20:03:19 EDT
It also crashes X. I have two Dell Inspiron 6400 notebooks, with Intel GMA 945, running compiz. Attempts to login result in X crashing. Reverting to mesa-libGL-7.5-0.14.fc11.i586 fixed the problem.
Comment 2 David Farler 2009-07-10 08:21:49 EDT
Confirmed here on Lenovo Thinkpad R500 with Intel Mobile 4 chipset.

Games that use OpenGL pretty much guarantee a hard lockup (I get kernel oopses) on start of any 3D rendering scene.

Downgrading to mesa-libGL, mesa-libGLU, and mesa-dri-drivers to 7.5 fixed the problem, so it is definitely the 7.6 packages that are messing me up.

For now, I have an exclude on those packages in yum.conf, but it's messing up dependencies for other packages that I'd like to have, so I hope this gets fixed soon.

Any other testing or additional information you'd like, just let me know.
Comment 3 David Farler 2009-07-10 08:27:09 EDT
Call Trace from related kernel oops if it helps:

[<f7fe2546>] ? i915_gem_fault+0xa0/0x102 [i915]
[<c048aa25>] ? __do_fault+0x41/0x342
[<c048aff0>] ? handle_mm_fault+0x2ca/0x6fb 
[<c0709741>] ? do_page_fault+0x2b3/0x653
[<c0532929>] ? inode_has_perm+0x60/0x6a
[<c0535d30>] ? selinux_capable+0x21/0xc1
[<c0707b31>] ? unlock_kernel+0x28/0x2b
[<c04aa488>] ? vfs_ioctl+0x62/0x74
[<c04aad29>] ? do_vfs_ioctl+0x480/0x4ba
[<c04a6b98>] ? path_put+0x1a/0x1d
[<c0464fff>] ? audit_syscall_exit+0xec/0x101 
[<c070948e>] ? do_page_fault+0x0/0x653
[<c0707be7>] ? error_code+0x77/0x80

This crash is 100% reproducible in my circumstances.
Comment 4 Howard Ning 2009-07-10 18:10:50 EDT
I can also get this kernel panic with my thinkpad X200s with GMA4500MHD when the xmoto hard lockuup.
Comment 5 Thomas Spura 2009-07-11 13:02:01 EDT
This should be a duplicate of bug #509519
Comment 6 Ricardo Schmidt 2009-08-16 13:06:02 EDT
Hello, Im experiencing the same problems with mesa 7.6-0.1. 
Im running Fedora 11 in an Acer 5738-6753 and my driver is an Intel GMA 4500MHD

Additional Info:
glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Mesa DRI Mobile Intel® GM45 Express Chipset GEM 20090114 

lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

rpm -qa |grep intel
xorg-x11-drv-intel-2.7.0-7.fc11.x86_64

Thread in fedoraforums.org created by me about this issue related with desktop effects: http://forums.fedoraforum.org/showthread.php?p=1251582 (screenshot included)

I would be happy in helping solving this problem by sending needed information.
Comment 7 Ricardo Schmidt 2009-08-16 13:12:17 EDT
Created attachment 357582 [details]
Screenshot Destkop Effects active with mesa 7.6-0.1 in Intel GMA 4500MHD

Login screen is normal, when logged in came with this garbled screen. If not Desktop Effects not activated the screen is normal, but if I try to activate it like in this screenshot...  
Downgrading the mesa packages solved the problem.
Comment 8 Alan Hamilton 2009-08-17 17:48:01 EDT
This may have tweaked the kernel bug 509519, but the latest version of the kernel no longer crashes.  However, I'm still seeing X getting a hang with mesa 7.6 and Google Earth.  Downgrading to mesa 7.5 resolves the lockup.

System Information
        Manufacturer: LENOVO
        Product Name: 2081CTO
        Version: ThinkPad T500
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset
Integrated Graphics Controller (rev 07) (prog-if 00 [VGA controller])
Comment 9 Ricardo Schmidt 2009-08-19 23:13:39 EDT
Works perfect now. I think the kernel update fixed it. 
Im not using advanced 3d aplications, just compiz-fusion for the desktop effects.

[esmit@schmidt ~]$ rpm -qa | grep mesa
mesa-libGL-devel-7.6-0.1.fc11.x86_64
mesa-dri-drivers-7.6-0.1.fc11.x86_64
mesa-libGL-7.6-0.1.fc11.x86_64
mesa-libGLU-7.6-0.1.fc11.i586
mesa-libGLU-7.6-0.1.fc11.x86_64
mesa-dri-drivers-7.6-0.1.fc11.i586
mesa-libGL-7.6-0.1.fc11.i586
mesa-libGLU-devel-7.6-0.1.fc11.x86_64
[esmit@schmidt ~]$ rpm -qa | grep kernel
kernel-firmware-2.6.29.6-217.2.8.fc11.noarch
kernel-devel-2.6.29.6-217.2.3.fc11.x86_64
kernel-2.6.29.6-217.2.8.fc11.x86_64
dracut-kernel-0.8-1.fc11.x86_64
kerneloops-0.12-5.fc11.x86_64
kernel-headers-2.6.29.6-217.2.8.fc11.x86_64
kernel-2.6.29.6-217.2.7.fc11.x86_64
kernel-2.6.29.6-217.2.3.fc11.x86_64
kernel-devel-2.6.29.6-217.2.7.fc11.x86_64
kernel-devel-2.6.29.6-217.2.8.fc11.x86_64
[esmit@schmidt ~]$ rpm -qa | grep intel
xorg-x11-drv-intel-2.7.0-7.fc11.x86_64
[esmit@schmidt ~]$
Comment 10 Bojan Smojver 2009-08-20 01:15:11 EDT
I just tried the other day on one of my Dell notebooks and got X crashing again.
Comment 11 Howard Ning 2009-08-20 06:50:03 EDT
The kernel update does fix the kernel panic error. But the 3D apps can still not run proper in my Thinkpad X200 with GMA 4500MHD
Comment 12 Ricardo Schmidt 2009-08-20 18:36:46 EDT
I just started the machine today, and it was fully crashed again. This is being very annoying, since I already set the autoupdates off and it auto updated, but I saw that and got amazed that it was working with the new mesa, but I think that it was not yet restarted.. The mesa was updated, but running the old working... Im very sad with this situation.
Comment 13 Bojan Smojver 2009-08-28 06:09:29 EDT
Is anyone looking to fix this bug? Do we know what's causing this?
Comment 14 Bojan Smojver 2009-09-06 20:17:23 EDT
Just for the record, the latest kernel (kernel-PAE-2.6.30.5-43.fc11.i686) doesn't make any difference here. X still crashes consistently.
Comment 15 Baif 2009-09-08 06:33:33 EDT
I test Fedora 11 KDE-Live CD x64, enabling Desktop Effects with openGL works. 

But, Fedora 12 Alpha KDE-Live CD x64, enable Desktop Effects with openGL doesn't work.

on laptop ThinkPad X61.
Comment 16 Bojan Smojver 2009-09-11 04:24:21 EDT
Could we get the latest mesa git snapshot built for F-11, so that we can at least test it?
Comment 17 Paul Thomas 2009-10-24 01:47:41 EDT
On Fedora 12 with mesa* at 7.6-0.13.fc12 I get severe graphics problems with certain applications. When I get the problem it doesn't seem to crash anything it just scrambles everything. With KDE & firefox everything scrambles pretty fast. With XFCE firefox works most of the time, but googleearth scrambles everything quickly.

How do I downgrade to mesa 7.5?

thanks,
Paul
Comment 18 Howard Ning 2009-10-24 19:19:34 EDT
Has the developer paid attention to this problem? It has been here for a long time but still not assigned.
The 7.6 is official released, we do not have to use the git version. and 7.6.1 will come soon.
Also, the 7.5.2 is stable enough.
Comment 19 Paul Thomas 2009-10-26 00:33:08 EDT
Thought I should mention my graphics is Radeon X1200 Series (Gateway lt3103u laptop).

thanks,
Paul
Comment 20 Bojan Smojver 2009-10-27 21:35:47 EDT
Can we have this reverted please to the version that works?

Even people that are running what is to become F-12 are having trouble.
Comment 21 Paul Thomas 2009-10-28 21:48:42 EDT
Did a yum update. Saw the xorg ATI driver got updated (xorg-x11-drv-ati.x86_64 6.13.0-0.10.20091006git457646d73.fc12), but the graphics still gets scrambled.

thanks,
Paul
Comment 22 Matěj Cepl 2009-11-05 13:34:04 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 23 Paul Thomas 2009-11-05 20:35:39 EST
Matej,

I just created a new bug report (# 533310), so not to confuse this with the Intel heading or non-rawhide versions.

thanks,
Paul
Comment 24 Matěj Cepl 2009-11-09 05:13:43 EST
*** Bug 510161 has been marked as a duplicate of this bug. ***
Comment 25 Howard Ning 2009-11-09 08:18:12 EST
I think the bug is gone with the newest kernel update.
Comment 26 Matěj Cepl 2009-11-10 12:40:48 EST
Thank you for letting us know.
Comment 27 Mariano Suárez-Alvarez 2009-11-10 13:16:25 EST
*What* kernel update?

For a bug that affects so many users, I have to say the number of datapoints that sufficed to get it to CLOSED state is slightly worrying...
Comment 28 Bojan Smojver 2009-11-10 16:25:53 EST
This bug was filed against F-11. Howe can it be closed by something that's in Rawhide? Shouldn't we get an F-11 update that fixes it?
Comment 29 Thomas Spura 2009-11-10 18:38:30 EST
(In reply to comment #26)
> Thank you for letting us know.  

I already reported, that this issue is fixed for me in the kernel bug [1] with the a *very* similar trace:

Compare Comment #3 from here and bug #509519 comment #79.

Maybe the kernel bug can be closed, too. The 3 latest comments there could be a different bug...

[1] https://bugzilla.redhat.com/show_bug.cgi?id=509519#c94
Comment 30 Howard Ning 2009-11-11 17:15:32 EST
It can be closed. I tried Nexuiz, xmoto can run without any problem. But only blender crashes.
Comment 31 Bojan Smojver 2009-11-12 01:26:01 EST
I'm just upgraded one of my Dell Inspiron 6400 machines to F-12 and it is not crashing any more.
Comment 32 Bojan Smojver 2009-11-12 04:01:11 EST
Sure enough - there is now a different problem - compiz slowed to a crawl, completely unusable. I'll look for another bug.
Comment 33 Howard Ning 2009-11-12 07:54:36 EST
(In reply to comment #31)
> I'm just upgraded one of my Dell Inspiron 6400 machines to F-12 and it is not
> crashing any more.  

Yes, Blender works fine on F12.

Note You need to log in before you can comment on or make changes to this bug.