Bug 509530 - Xulrunner will not reslove hostnames
Xulrunner will not reslove hostnames
Status: CLOSED DUPLICATE of bug 508481
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-03 06:22 EDT by Ola Thoresen
Modified: 2009-07-03 16:48 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-03 16:48:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ola Thoresen 2009-07-03 06:22:01 EDT
Description of problem:
After an update today xulrunner (at least both Firefox and Thunderbird) will not resolve any hostnames.  
After chnaging hostnames to IP-addresses for both SMTP and IMAP-servers in Thunderbird mail works again.
I can also browse websites with IP-addresses (IE http://195.159.1.4/) but any hostname just gives the error:
Server not found

Firefox can't find the server at www.powertech.no

tcpdump does not show any hostname-lookups at all (no traffic on port 53) and the problem is present both with nscd enabled and disabled, and after invalidating hosts in nscd.

Ping works fine, browsing with a non-xulrunner browser (Opera) works fine, ssh works fine, resolving hostnames via both "host", "nslookup" and "dig" works so it is NOT a network- or DNS-issue.  

Version-Release number of selected component (if applicable):

xulrunner-1.9.1-2.fc12.x86_64
firefox-3.5-1.fc12.x86_64
thunderbird-3.0-2.4.b3pre.hg.6a6386c16e98.fc11.x86_64

How reproducible:
Allways

Steps to Reproduce:
1. Open any website in firefox
2. Check or send mail with Thunderbird and hostnames (not IP-addresses) in the server-fields.
  
Actual results:
No connection

Expected results:
Well..

Additional info:
On a side-note, Thunderbird will actually _crash_ trying to send mail with a hostname as the smtp-server.  Changing to IP-address works fine.
Comment 1 Yanko Kaneti 2009-07-03 06:39:09 EDT
You said its not a DNS issue , but please, indulge us. What does 
$ grep ^hosts /etc/nsswitch.conf
say?
Comment 2 Parag Nemade 2009-07-03 06:41:10 EDT
just look at how to fix this in bug 508481
Comment 3 Ola Thoresen 2009-07-03 07:32:22 EDT
What I meant with "not a dns-issues" is that my DNS-servers are wirking fine, and other applications (ping, ssh, opera ...) is able to resolve hosts.

But you are right. Installing nss-mdns-0.10-7.fc11.x86_64 fixed the problem.

Thanks.
Comment 4 Matěj Cepl 2009-07-03 16:48:04 EDT

*** This bug has been marked as a duplicate of bug 508481 ***

Note You need to log in before you can comment on or make changes to this bug.