Bug 50954 - Non-intutive error message
Non-intutive error message
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-05 12:59 EDT by Peter Bowen
Modified: 2015-01-07 18:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-16 12:54:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bowen 2001-08-05 12:59:55 EDT
Description of Problem:
After upgrading from Zoot to Roswell, up2date give the following
non-intutive error message:

Error communicating with server.  The message was:
While running 'up2date.login': caught
apacheServer.UnknownXML : Invalid request received (function: up2date.login
invalid).

up2date should contain user friendly error message translations for
low-level XML-RPC errors, such as the one above.  This error message occurs
when the /etc/sysconfig/rhn/up2update contains a really outdated server
(e.g. priority.redhat.com).  It should tell the user to run up2date
--configure to fix this problem. (or whatever the correct solution is)
Comment 1 Glen Foster 2001-08-06 18:40:37 EDT
We (Red Hat) should try to fix this for the next release.
Comment 2 Michael Young 2001-08-07 11:59:50 EDT
I had the same problem. I tried various things, but I think the problem was
/etc/sysconfig/rhn/up2date still had an entry pointing at the main rhn server,
not the beta one. I replaced this with the up2date.rpmnew file and reapplied my
customizations, and the update now seems to get much further - it times out
while trying to get the patch list. (An up2date -p may also be necessary after
the change).
Comment 3 Michael Young 2001-08-07 12:03:23 EDT
I should have mentioned my upgrade was from seawolf to roswell.
Comment 4 Cristian Gafton 2001-08-10 16:57:00 EDT
Assigned to the owner of component
Comment 5 Adrian Likins 2001-08-10 18:24:17 EDT
This is an artificate of the beta period. The new client uses a new
server api, that the current www.rhns.redhat.com servers dont support.

Since this was an update, your up2date config is still pointing
at these new servers instead of at beta.rhns.redhat.com, which
does support this new server function. 

Easiest thing to do is probabaly to copy over the .rpmnew files
for /etc/sysconfig/rhn/{up2date,rhn_register}

The live servers will soon support this new api as well.
Comment 6 Peter Bowen 2001-08-10 19:39:48 EDT
I didn't mean this bug to be about the exact error message, but the fact that
up2date was throwing crypting errors in general.  It should present the user
with a more user friendly error message, with a suggestion for a possible fix,
or someone to contact for more info.
Comment 7 Adrian Likins 2001-08-10 19:57:12 EDT
the next version of the client does (it catches this xmlrpc fault
and presents a  error dialog explaining how to fix it).

Comment 8 Peter Bowen 2001-08-16 12:54:41 EDT
I can't get the client to throw this error anymore.
Comment 9 Jay Turner 2001-08-16 13:02:45 EDT
Closing out this issue then.

Note You need to log in before you can comment on or make changes to this bug.