Bug 509542 - No sound on fresh install F11. Laptop model Asus K40IJ.
No sound on fresh install F11. Laptop model Asus K40IJ.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-03 07:48 EDT by Ahmad Zulkarnain
Modified: 2010-06-28 09:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 09:27:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmseg log (38.07 KB, application/octet-stream)
2009-07-03 07:48 EDT, Ahmad Zulkarnain
no flags Details
alsa-info.sh output (74 bytes, text/plain)
2009-07-03 07:49 EDT, Ahmad Zulkarnain
no flags Details
dist.conf (5.48 KB, application/octet-stream)
2009-07-03 07:49 EDT, Ahmad Zulkarnain
no flags Details
Diff file from HDA Analyzer (647 bytes, patch)
2009-07-06 03:33 EDT, Ahmad Zulkarnain
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
ALSA Project 4613 None None None Never

  None (edit)
Description Ahmad Zulkarnain 2009-07-03 07:48:29 EDT
Created attachment 350410 [details]
dmseg log 

Description of problem:
Fresh install of F11 from DVD. no sound audible from speakers or headphone jack. Laptop model: Asus K40IJ BIOS revision number: 207.


Version-Release number of selected component (if applicable):
alsa-lib-1.0.20-1.fc11.i586

How reproducible:
Often

Steps to Reproduce:
1. Fresh install of F11 from source media,including any media players with sufficient codec.
2. boot into F11 normally
3. select a sound file aplay -pluginhw0,0 foo.wav OR trying playing any mp3/sound file using mplayer etc.
  
Actual results:
No sound audible from both speakers or headphone jack. using PulseAudio volume control indicates that there is sound streaming but none audible.

Expected results:
Audible sound from startup and from media players.

[nocturnus@roadwarrior ~]$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: VT1708S Analog [VT1708S Analog]
  Subdevices: 2/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1

[nocturnus@roadwarrior ~]$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

[nocturnus@roadwarrior ~]$ alsactl init
Unknown hardware: "HDA-Intel" "VIA VT1708S" "HDA:11060397,10431111,00100000" "0x1111" "0x1043"
Hardware is initialized using a guess method


Additional info:
Linux localhost.localdomain 2.6.29.5-191.fc11.i686.PAE #1 SMP Tue Jun 16 23:19:53 EDT 2009 i686 i686 i386 GNU/Linux
Comment 1 Ahmad Zulkarnain 2009-07-03 07:49:19 EDT
Created attachment 350411 [details]
alsa-info.sh output
Comment 2 Ahmad Zulkarnain 2009-07-03 07:49:53 EDT
Created attachment 350412 [details]
dist.conf
Comment 3 Ahmad Zulkarnain 2009-07-06 03:33:09 EDT
Created attachment 350579 [details]
Diff file from HDA Analyzer

After using HDA-Analyzer, and adjusting Node[0x1c] PIN, initial settings show that EAPD is not set. Checking the EAPD option allows sound to be heard, although it is very very low, with all the mixer settings maxed out on any media (audacious,xmms,mplayer, youtube stream).
Comment 4 Ruthira 2009-08-11 00:51:04 EDT
Hi Ahmad,

Did you find a solution?  I'm having K40IJ as well.  tried many of the solutions on the web, none worked.  btw, how did you set the EAPD option?
thanks
Comment 5 Ahmad Zulkarnain 2009-08-11 04:56:33 EDT
Well I kinda forgot about this bug report to be honest but i gotten the sound to work. I downloaded and install the latest alsa driver. and then i used hda-verb to enable the EAPD automatically on startup.
here's how to do it.

--- commands start here ---
sudo -s
wget ftp://ftp.kernel.org/pub/linux/kernel/people/tiwai/misc/hda-verb/hda-verb-0.3.tar.gz
tar xf hda-verb-0.3.tar.gz
cd hda-verb-0.3
make
cp hda-verb /usr/bin
--- command ends ---

then add this line into /etc/rc.d/rc.local by doing
sudo nano /etc/rc.d/rc.local

and insert the following line:
hda-verb /dev/snd/hwC0D0 0x1c SET_EAPD_BTLENABLE PCM
Comment 6 Ruthira 2009-08-15 00:46:07 EDT
Thanks bro

Since i'm not familiar the updating of alsa driver, i tried the rest of your instruction.  didn't work, but noticed some errors:
1. i dont have the rc.local directory in my system.  so i created one (with sudo)
2. the /dev/snd/hwC0D0 didn't exist (only PCMC0D0c, PCMC0D0p)

could it be because i'm using ubuntu (9.04)?  

not urgent, reply in your spare time.  thank you again.
Comment 7 Ahmad Zulkarnain 2009-08-15 03:26:47 EDT
interesting.

I will have to see how the directory structure of ubuntu to help you further. give me a couple of days(maybe more) while i try and work something out. i do have a spare HDD to install ubuntu into the K40IJ (maybe).

alternatively you could try the steps shown here http://alsa-project.org/main/index.php/Matrix:Module-hda-intel for upgrading the alsa-drivers

another link i found was from http://ubuntuforums.org/showthread.php?p=6589810#post6589810 a script which allows users to update the alsa packages.

as well as https://bugs.launchpad.net/ubuntu/+source/linux/+bug/393523 which uses the same technique to force the EAPD flag to be toggled on bootup.

i'm almost certain that the /dev/snd/hwC0D0 directory exists across all distributions assuming that the alsa-drivers are updated.

let me know what happens.
Comment 8 Bug Zapper 2010-04-27 11:27:11 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2010-06-28 09:27:30 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.