Bug 509553 - [REG] less does not display long lines properly when scrolling line per line
[REG] less does not display long lines properly when scrolling line per line
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: less (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Nikola Pajkovsky
BaseOS QE
: Patch, Rebase, Regression
Depends On:
Blocks: 499522 510724 5.5TechNotes-Updates
  Show dependency treegraph
 
Reported: 2009-07-03 09:31 EDT by Olivier Fourdan
Modified: 2014-02-02 17:13 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
: 510724 (view as bug list)
Environment:
Last Closed: 2010-03-30 04:17:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed patch (backport from upstream) (8.05 KB, patch)
2009-07-03 09:31 EDT, Olivier Fourdan
no flags Details | Diff

  None (edit)
Description Olivier Fourdan 2009-07-03 09:31:05 EDT
Created attachment 350434 [details]
Proposed patch (backport from upstream)

Description of problem:

The fix for bug #441691 introduced a regression less, it does not display lines longer that screen width properly, when scrolling line per line.

Version-Release number of selected component (if applicable):

less-394-6.el5

How reproducible:

100% reproducible

Steps to Reproduce:
1. Open a 80x25 terminal
2. less /var/log/messages
3. press "enter" or "cursor down" to scroll line per line
  
Actual results:

The lines are truncated, and the same lines are repeated 

Expected results:

The lines display correctly

Additional info:

The patch "less-394-newline.patch" from bug #441691 that went in 
less-394-6.el5 seems incomplete.

Attached patch backports the missing bits from upstream (for the option --old-bot that was partially introduced in less-394-6.el5).
Comment 5 Olivier Fourdan 2009-07-07 12:43:28 EDT
Sorry, I just find out that the proposed patch is not complete either.

When browsing a man page with the arrow cursor down key, the following message appears at times:

: ESCOB

This did not happen before. So the patch is either incomplete or not totalyl appropriate.
Comment 6 Olivier Fourdan 2009-07-09 11:19:32 EDT
(In reply to comment #5)
> When browsing a man page with the arrow cursor down key, the following message
> appears at times:
> 
> : ESCOB
> 
> This did not happen before. So the patch is either incomplete or not totalyl
> appropriate.  

That particular problem is also present in less-418 but seems to be fixed in less-429
Comment 14 Ben 2010-01-22 07:13:11 EST
Can someone tell me when a fix for this bug will be released, please?  Every RHEL5.4 (fully patched) box I have, when scrolling through long files with long lines, garbles the display of a file.  Paging through using the space bar works fine.  Pressing ctrl-l after the output becomes garbles also works but I was really hoping that line-by-line scrolling would also work.

Is there an ETA on this bug being resolved?

With thanks.
Comment 15 Olivier Fourdan 2010-01-22 07:33:44 EST
Ben, you may want to try the "--old-bot" option as a workaround as described in this KBase article: http://kbase.redhat.com/faq/docs/DOC-17739
Comment 16 Ben 2010-01-22 07:41:01 EST
Awesome!  That fixes my immediate problem.

Is there an actual long term solution or am I going to have to change every user's .*profile on every single RHEL5 workstation and server to alias less to "less --old-bot"?

Thanks for the pointer.
Comment 17 manuel wolfshant 2010-01-22 07:48:11 EST
Ben, you do know that you could change /etc/bashrc, right ?
Comment 18 Nikola Pajkovsky 2010-01-22 07:54:40 EST
we have a plan to rebase less in RHEL5.
Comment 19 Ben 2010-01-22 08:59:19 EST
manuel: Sorry, I was having a Solaris moment and forgot entirely about /etc/bashrc.  Having to do every machine is admittedly slightly less annoying than doing every user on every machine.

Nikola: That's great.  Thank you.  I'll assume 5.5 or 5.6.  Either way, enough time from now to make changing /etc/bashrc worthwhile.


Apologies all round, generally.
Comment 22 errata-xmlrpc 2010-03-30 04:17:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0214.html
Comment 24 Adam T. Bowen 2010-03-30 06:26:40 EDT
Is there a time delay for this errata to be published? It has been two hours now and I'm still getting a 404.

(Sorry about adding this as a comment, but I'm presuming "errata-xmlrpc" isn't a human, so an email to it about this problem would be futile.)

Note You need to log in before you can comment on or make changes to this bug.