Bug 509585 - [RHEL 5.3] problems changing coalesce settings <=12us on bnx2x
[RHEL 5.3] problems changing coalesce settings <=12us on bnx2x
Status: CLOSED DUPLICATE of bug 522600
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Flavio Leitner
Red Hat Kernel QE team
:
Depends On:
Blocks: 533192
  Show dependency treegraph
 
Reported: 2009-07-03 14:59 EDT by Flavio Leitner
Modified: 2010-11-09 07:24 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-09 02:19:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch fixing rx coalesce (2.05 KB, patch)
2009-07-06 13:39 EDT, Flavio Leitner
no flags Details | Diff

  None (edit)
Description Flavio Leitner 2009-07-03 14:59:05 EDT
Description of problem:

  Setting to anything <= 12 causes all network traffic to 'disappear',
  cannot ping, telnet, etc.
  Bringing the interface down, then setting to > 12 will correct the issue.


Version-Release number of selected component (if applicable):
  RHEL 5.3 x86_64 (-155 from dzickus tested as well)


How reproducible:
  Always


Relevant code:
static int bnx2x_set_coalesce(struct net_device *dev,
                             struct ethtool_coalesce *coal)
{
       struct bnx2x *bp = netdev_priv(dev);

       bp->rx_ticks = (u16) coal->rx_coalesce_usecs;
       if (bp->rx_ticks > 3000)
               bp->rx_ticks = 3000;
...
       if (netif_running(dev))
               bnx2x_update_coalesce(bp);

and

static void bnx2x_update_coalesce(struct bnx2x *bp)
{
               REG_WR8(bp, BAR_USTRORM_INTMEM +
                       USTORM_SB_HC_TIMEOUT_OFFSET(port, sb_id,
                                                   U_SB_ETH_RX_CQ_INDEX),
                       bp->rx_ticks/12);

Usually a code like that 'rx_ticks/12' means the board register accepts
multiples of 12, so you can configure 0us, 12us, 24us, 36us, 48us, 60us...
Upstream does that too.
Broadcom driver does that too.

I looks like a hardware limitation, though I don't have any detailed
board specification to make sure.

However, it should not stop working because someone tried to configure
a value less or equal 12us.
Comment 5 Flavio Leitner 2009-07-06 13:39:13 EDT
Created attachment 350651 [details]
patch fixing rx coalesce 

Hi,

I've received a feedback from Broadcom on this. The FW supports coalescing
in 12us granularity, and so value of less then 12 should be interpreted as
disabling coalescing.

Could you give a try on the attached patch?

thank you,
Flavio
Comment 16 Stanislaw Gruszka 2010-02-09 02:19:15 EST
I missed/forgot about that bug. It is duplicate (already solved).

*** This bug has been marked as a duplicate of bug 522600 ***

Note You need to log in before you can comment on or make changes to this bug.