Bug 509623 - mplayer and family hangs all 3 of my x86_64 machines
mplayer and family hangs all 3 of my x86_64 machines
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kmplayer (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-04 03:38 EDT by Mohammed Arafa
Modified: 2009-09-12 20:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-12 20:00:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Arafa 2009-07-04 03:38:09 EDT
Description of problem:
i have 3 x86_64 machines and 1 32bit laptop. the 64bit machines have the same symptoms: running mplayer, gmplayer, kplayer with any movie (mpg or avi) or song (mp3 or flac) will cause the GUI (kde is what i use) to hang while leaving the mouse working. i then have to ssh into the machine to take back control of the system.
the 32bit machine works with movies and songs

they are all f11 and updated daily.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Sergio Morais Lietti 2009-07-09 12:30:30 EDT
Same problem, but with two 32bit machines (desktop dell optiplex gx280 and laptop dell latitude d520) with fedora11 and gnome. 
Running gmplayer, xine with any movie (mpg, avi, wmv), or when firefox reproduces these movies using the Gecko Media Player plugin, will cause the GUI (gnome) to hang while leaving the mouse working but the only way to take back control of the system is to ssh into the machine.
Comment 2 Rex Dieter 2009-07-19 15:02:28 EDT
Not sure where the bug is, but it certainly is not specific to kmplayer.

As mplayer isn't even distributed by fedora, I'd suggest taking this issue to bugzilla.rpmfusion.org against mplayer

Re: comment #1 , hanging on *any* moving by virtually any movie player is even a more generic/vague problem.  Not sure how or where best to classify that.

Now, if anyone can reproducibly find bugs with fedora-only content (fedora players, using free codecs such as ogg), feel free to mention those here.
Comment 3 Mohammed Arafa 2009-07-20 00:44:01 EDT
hi rex

you have valid points but this affects kmplayer as well which is distributed by fedora.

i will be testing kmplayer with an ogg movie later and get back to you with my result.

i will also change the engine as part of my test.

thanks
Comment 4 Mohammed Arafa 2009-08-02 17:08:04 EDT
tested kmplayer with an ogg movie and it too hangs.

tested smplayer and that too hangs.

tested vlc with ogg. no problems

tested vlc with avi. no problems

tested via ssh -Y remote_x86_64_pc smplayer video.avi and that too hangs. 

this last case needs a little clarification. the system that hangs is NOT the remote machine that always hangs but the local 32bit machine that in comment #1 i said does not hang.

any advice?
Comment 5 Rex Dieter 2009-08-02 17:32:49 EDT
I still think this is an mplayer-specific issue that should be taken up with it's maintainer(s) @ rpmfusion.

To re-enforce that, I can now reproduce failures, even when using mplayer directly,
mplayer foo.avi
Comment 6 Orcan Ogetbil 2009-08-02 18:26:42 EDT
I can't reproduce any of the reported issues on my F-10 and F-11 machines.

(In reply to comment #5)
> I still think this is an mplayer-specific issue that should be taken up with
> it's maintainer(s) @ rpmfusion.
 
Normally, yes. But Rathann is, and will be away for a while. Our ffmpeg/mplayer stack needs a new maintainer.
Comment 7 Steven M. Parrish 2009-09-12 20:00:22 EDT
Closing this as CANTFIX as it needs to be handled by the RPMFUSION folks.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.