This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 509636 - Software Log Viewer filter box scrambles entered text
Software Log Viewer filter box scrambles entered text
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-04 06:45 EDT by Steve Bryant
Modified: 2009-07-16 03:24 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.27.3-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-04 17:04:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Bryant 2009-07-04 06:45:35 EDT
Description of problem:
The Software Log Viewer applet (/usr/bin/gpk-log) has a filter box that allows you to display only the updates that contain the entered string.  Despite there being a "Filter" button, it searches the installed package list a short time after each character is entered.  The "Filter" button appears now to obsolete.

If the characters are entered reasonably quickly (i.e. before the search for the previous character completes and it displays on the filter bar), the sequence of such characters is reversed.

Version-Release number of selected component (if applicable):
gnome-packagekit-2.27.2-1.fc11.i586

How reproducible:
Type in the filter box reasonably quickly.

Steps to Reproduce:
1. Type a search term such as "kernel", "ker" (pause then add) "nel", or "fred"
2.
3.
  
Actual results:
"lenrek", "reklen", or "derf" appear in the seach box and are used to filter the installed packages.

Expected results:
"kernel", "kernel", or "fred" appear in the filter box ... with characters in the order typed(!)

Additional info:
Comment 1 Steve Bryant 2009-07-04 07:09:37 EDT
Once the filter text entered returns no matches, any further text entered is no longer scrambled but appears as typed.  This indicates that the issue could be caused by the applet initially searching the installed packages as each character is typed.
Comment 2 Richard Hughes 2009-07-04 17:04:00 EDT
commit 30df1f2c1f4319e3006b6cb782f26b0c3be8f7e0
Author: Richard Hughes <richard@hughsie.com>
Date:   Sat Jul 4 22:02:40 2009 +0100

    Don't connect to key press _and_ release in gpk-log. Fixes rh#509636

Next release on Monday, I'll backport to F11 if there are no problems for a few days in rawhide.
Comment 3 Fedora Update System 2009-07-06 08:34:50 EDT
gnome-packagekit-2.27.3-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gnome-packagekit-2.27.3-1.fc11
Comment 4 Fedora Update System 2009-07-16 03:24:09 EDT
gnome-packagekit-2.27.3-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.