Bug 50964 - Can't open a groff file with gxditview
Summary: Can't open a groff file with gxditview
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: groff   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-05 18:59 UTC by Chris Negus
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-15 10:44:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Negus 2001-08-05 18:59:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010725

Description of problem:
While testing the groff-gxditview package, I tried to use the gxditview
command to print different groff output files. The result was 100 or more
blank pages in each case. When gxditview was called directly from groff
(with -X option) it worked well in most cases.

Because there is no docs with gxditview, I relied on a man page from the
Web to find out what it was supposed to do. If only working from groff -X
(and with only certain devices) is acceptable, you can close this bug and
pass the package. It works well in the limited ways I describe below.

How reproducible:
Always

Steps to Reproduce:
1.Unzip any man page (gunzip groff.1.gz)
2.Use groff to format the page (groff -man -Tps -X groff.1). The gxditview
window opens and groff man page displays nicely.
3.Direct output to a file, then open in gxditview.(groff -man -Tps groff.1
> /tmp/groff.ps;gxditview /tmp/groff.ps
	

Actual Results:  gxditview opened with 159 blank pages. (At least I think
they were all blank. I didn't actually check every one.)

Expected Results:  I expected to be able to open the file directly with
gxditview so that it would work as it does using the -X option to groff.

Additional info:

I tried all the output devices listed on the man page I found for groff.
Here are the ones that could display with gxditview (called by groff -X):

ps
X75
X100
lj4
html

Here are the ones that couldn't:

dvi
ascii
ascii8
utf8
cp1047
nippon
lbp

Comment 1 Glen Foster 2001-08-06 22:42:47 UTC
We (Red Hat) should try to fix this for the next release.

Comment 2 Florian La Roche 2001-08-14 13:18:34 UTC
This seems to work fine for me:

troff -man -r.X=1 -Tps manpage.1 > manpage.ps; gxditview manpage.ps

Florian La Roche


Comment 3 Thomas Woerner 2004-01-15 10:44:59 UTC
man gxditview:

>DESCRIPTION
>       The  gxditview program displays gtroff output on an X display.
       
>       It uses the standard X11 fonts, so it does not require access 
>       to the server ...

You have to use gtroff, not groff.

'gtroff -man <manpage> | gxditview -' works.



Note You need to log in before you can comment on or make changes to this bug.