Bug 509660 - g-p-m fails to put display back to sleep after woken up with only a single keypress
g-p-m fails to put display back to sleep after woken up with only a single ke...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 497669 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-04 14:46 EDT by Jason Farrell
Modified: 2010-02-17 23:07 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 12:11:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Farrell 2009-07-04 14:46:25 EDT
Description of problem:
The display will not be put to back into powersave after being woken up after only a *single* keypress; a *second* keypress is needed after the display is woken up. It is not expected behavior to have to somehow know to press a key twice in order for it to go to sleep again.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.26.2-1.fc11.i586

Steps to Reproduce:
1. under System -> Prefs -> ScreenSaver: disable the screensaver if enabled as it's not required to reproduce, and then reduce the idle timeout to 1 minute (to allow powersave timeout to be reduced more for faster testing)
2. under 'Power Management' set 'Put display to sleep when inactive for' 1
minute.
3. after 1 minute when the screen is put to sleep, press any key to wake the display up, and then, crucially, press any other key ONE MORE TIME *after* the display has woken up. (repeat this step a few times and the display will consistently sleep/wake cycle)
4. wait 1 more minute for the display to go to sleep again, but this time press any key only *ONCE* to wake it up, and press nothing else, then wait (in vain) for next N minutes for nothing to happen.
  
Actual results:
The display is never put to sleep again, apparently because only keypress activity after the display is awake counts to reset the idle timer.

Expected results:
powersave always working; a backlight left on kills batterylife.
Comment 1 Jason Farrell 2009-07-04 14:50:05 EDT
*** Bug 497669 has been marked as a duplicate of this bug. ***
Comment 2 Tim Taiwanese Liim 2009-07-11 21:52:41 EDT
This bug
    bug508886 gnome-screensaver does not put display to sleep.
reported same issue, but with gnome-screensaver as the Component.  I
suggest we leave bug508886 open with g-ssaver as Component, to serve
as a pointer to this bug.

Workaround: 
  - after each display sleep, kill and restart g-p-m.  It appears that
    g-p-m works fine on first display sleep, so restart g-p-m ensures
    you have the "first display sleep."
  - this trick on 2 out of 3 laptops I tried.  Anyone knows a 
    sure-fire workaround please let us know.
Comment 3 Michal Jaegermann 2009-07-28 15:50:34 EDT
I just moved a machine F9->F11 and among multiple regressions I have this one. If  I have gnome-screensaver or xscreensaver going then a display does not blank.  Period.  Not even once (so maybe this is rather bug 508886).  I am only collecting in my logs (grep over /var/log/Xorg.0.log);

(II) Loading extension DPMS
(II) RADEON(0): DPMS capabilities: Off
(II) RADEON(0): DPMS capabilities: Off
(II) RADEON(0): DPMS capabilities: Off
(II) RADEON(0): DPMS enabled
(II) RADEON(0): DPMS capabilities: Off
(II) RADEON(0): DPMS capabilities: Off
(II) RADEON(0): DPMS capabilities: Off
(II) RADEON(0): DPMS capabilities: Off
(II) RADEON(0): DPMS capabilities: Off
(II) RADEON(0): DPMS capabilities: Off
(II) RADEON(0): DPMS capabilities: Off
(II) RADEON(0): DPMS capabilities: Off
(II) RADEON(0): DPMS capabilities: Off
(II) RADEON(0): DPMS capabilities: Off

and these capabilities indeed seems to be going off.  Apparently only turning off screensavers completely does help.

I can also always turn off a screen with 'vbetool dpms off', although xset
seems to be totally ineffective.  For that one has to be root and the only way to get a screen back seems to be 'vbetool dmps on'.  Bummer!

OTOH in a normal use - say, when you are typing something in an editor - a screen may go blank in random times for two or three seconds.  So far it always comes back but it is very annoying.  Something similar was happening in Fedora 7
but later it was fixed.  That looks like a bug 243022 again but maybe only it looks.
Comment 4 Need Real Name 2009-07-30 14:45:56 EDT
Same here as in the original description.
gnome-power-manager-2.26.3-1.fc11.x86_64

This issue is very annoying - my display is often on the next morning...
Comment 5 Rick Richardson 2009-08-03 15:59:04 EDT
NOTE: I have five systems at F10, and one at F11.  Needless to say, this is a show stopper for upgrading the F10 -> F11 machines!
Comment 6 Richard Hughes 2009-08-20 08:05:41 EDT
Does installing the latest gnome-power-manager in updates-testing (and then rebooting...) fix the problem?
Comment 7 Rick Richardson 2009-08-20 08:20:07 EDT
[rick@kathleen ~]$ root yum install gnome-power-manager
Loaded plugins: dellsysidplugin2, refresh-packagekit
adobe-linux-i386                                         |  951 B     00:00     
livna                                                    | 2.4 kB     00:00     
rpmfusion-free-updates                                   | 3.8 kB     00:00     
rpmfusion-nonfree-updates                                | 3.8 kB     00:00     
updates/metalink                                         | 7.9 kB     00:00     
updates                                                  | 4.4 kB     00:00     
updates/primary_db                                       | 3.1 MB     00:02     
Setting up Install Process
Package gnome-power-manager-2.26.3-1.fc11.i586 already installed and latest version
Nothing to do


No dice!
Comment 8 Richard Hughes 2009-08-20 08:37:17 EDT
That's not updates-testing... Try the build here: http://koji.fedoraproject.org/koji/taskinfo?taskID=1617346
Comment 9 Rick Richardson 2009-08-20 11:41:47 EDT
gnome-power-manager.i586                 2.26.4-3.fc11                 installed

Same thing.  Does not work.

Screensaver Preferences -> Regard the computer as idle after -> 5 minutes

Power Management Preferences -> Put display to sleep when inactive for -> 15
minutes

Screensaver kicks in at 5 minutes.  But, after 15 minutes, it is still going
instead of putting the display to sleep.  Left it for a hour - still running.

This used to work on FC10 and before.
Comment 10 Tim Taiwanese Liim 2009-08-28 17:14:52 EDT
This does not work for me either.
    gnome-power-manager-2.26.4-3.fc11.x86_64

Another workaround.
  - Inside X, use the 'xset' command, like this: 
      xset dpms 300 300 300         # in seconds 
           first value given is for the "standby" mode,  
           the second is for the "suspend" mode, and  
           the third is for the "off" mode. 
    See "man xset" for details.  
    When I tried "xset dpms 10 10 10", the display actually
    slept after 10 sec, BUT comes back sometime later by 
    itself!  I have to use "xset dpms 10 10 0" to make it 
    happy.  Anyone knows why?

  - this is not good for video viewing, although good for
    a web server.

  - this "xset dpms" tricks again worked on 2 out my 3 laptops.
    All 3 used to work fine in F10.

  - For the stubborn one, I switch to tty2 (Ctrl-Alt-F2),
        echo -e "\033[14;10]"       # screen sleep in 10 minutes 
    See man "console_codes", search for "power".
       ESC [ 14 ; n ]      Set the VESA powerdown interval in minutes.

    This did the trick, turn off the backlight.  It's not
    perfect though; I tried to set it to 1 minute:
        echo -e "\033[14;1]"
    Still the sleep kicked in after 10 minutes.  
    Oh well.  At least my laptop backlight is not burning overnight.
Comment 11 Jason Farrell 2009-08-30 14:41:14 EDT
Using gnome-power-manager-2.26.4-3.fc11.i586 I am no longer able to reproduce the specific test case of my original bug report.

The display now DOES go back to sleep after only a single key event has woken it up. Yay batterylife.

(This bug should be closed, unless it's being used to track related issues in the comments)
Comment 12 Tim Taiwanese Liim 2009-10-17 00:58:03 EDT
Agree with Jason, this bug should be closed now that it is fixed.
For the past few weeks my two laptops has been behaving pretty
fine, both with single head (either built-in LCD or external LCD)
and with dual-head config.

A third laptop of mine still has problem turning off built-in
LCD; it has
    01:00.0 VGA compatible controller: ATI Technologies Inc M9+ 
            5C61 [Radeon Mobility 9200 (AGP)] (rev 01)
But since it has trouble with "xset dpms 10 10 0" in F11, I do
not attribute the issue to g-ssaver.  This same laptop was fine
in F10 (g-ssaver works just fine).  I will open a new bug for
this, when I figure out which module it should go to.
Comment 13 Jason Farrell 2009-10-21 12:11:40 EDT
Closing.

(there's still odd issues with g-p-m, but this isn't one anymore...)
Comment 14 Tim Taiwanese Liim 2010-02-17 23:07:16 EST
FYI: you might be interested in this bug:
bug566351 after interrupting the fading a few times, gnome-screensaver 
          no longer locks the screen

Note You need to log in before you can comment on or make changes to this bug.