Bug 509675 - Firefox persistantly crashes in Fedora 11
Firefox persistantly crashes in Fedora 11
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-04 19:04 EDT by Konstanty
Modified: 2010-03-09 09:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 507087
Environment:
Last Closed: 2010-03-09 09:27:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
One of the crashes (12.62 KB, text/plain)
2009-07-04 19:04 EDT, Konstanty
no flags Details
Crash report with "thread apply all backtrace" (16.23 KB, text/plain)
2009-07-05 01:55 EDT, Konstanty
no flags Details
Firefox crash in firefox nightly build (x86_64) (11.48 KB, text/plain)
2009-07-23 06:53 EDT, Konstanty
no flags Details

  None (edit)
Description Konstanty 2009-07-04 19:04:09 EDT
Created attachment 350516 [details]
One of the crashes

Description of problem:
Firefox crashes extremely often (several times per day) - however sometimes not consistantly in Fedora 11.

Version-Release number of selected component (if applicable):
firefox-3.5-1.fc11.x86_64

How reproducible:
Open firefox, click some links - crash.
(Also when reopening firefox it is likely to crash too - about half the time)
  
Actual results:
Crash

Expected results:
Works normally

Additional info:
I've run firefox through: firefox --debug and the backtraces do not seem the same every time. Sometimes it is in the JS, sometimes in layout.

Maybe one thing that is special about this system, was that it was installed as Fedora Release Candidate, and then upgraded to fedora 11?
(The crash also happened on firefox 3.5b4)
Comment 1 Konstanty 2009-07-04 19:06:05 EDT
$  rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*
firefox-3.5-1.fc11.x86_64
xulrunner-1.9.1-1.fc11.x86_64
plymouth-plugin-throbgress-0.7.0-0.2009.05.15.1.fc11.x86_64
gstreamer-plugins-good-0.10.15-1.fc11.x86_64
totem-mozplugin-2.26.2-1.fc11.x86_64
elisa-plugins-bad-0.5.35-1.fc11.noarch
gstreamer-plugins-bad-0.10.13-3.fc11.x86_64
PackageKit-yum-plugin-0.4.8-1.fc11.x86_64
alsa-plugins-pulseaudio-1.0.18-3.fc11.x86_64
xulrunner-debuginfo-1.9.1-1.fc11.x86_64
PackageKit-gstreamer-plugin-0.4.8-1.fc11.x86_64
java-1.6.0-openjdk-plugin-1.6.0.0-22.b16.fc11.x86_64
plymouth-plugin-label-0.7.0-0.2009.05.15.1.fc11.x86_64
firefox-debuginfo-3.5-1.fc11.x86_64
gstreamer-plugins-flumpegdemux-0.10.15-6.fc11.x86_64
anaconda-yum-plugins-1.0-4.fc11.noarch
xulrunner-devel-1.9.1-1.fc11.x86_64
mozilla-filesystem-1.9-4.fc11.x86_64
nspluginwrapper-1.3.0-5.fc11.x86_64
yum-plugin-fastestmirror-1.1.22-1.fc11.noarch
elisa-plugins-good-0.5.35-1.fc11.noarch
gstreamer-plugins-base-0.10.23-1.fc11.x86_64
flash-plugin-10.0.22.87-release.i386
setroubleshoot-plugins-2.0.18-1.fc11.noarch
gstreamer-plugins-farsight-0.12.10-2.fc11.x86_64
gstreamer-plugins-ugly-0.10.11-2.fc11.x86_64

(as requested in the original bug this is a clone of)
Comment 2 Konstanty 2009-07-05 01:55:11 EDT
Created attachment 350527 [details]
Crash report with "thread apply all backtrace"
Comment 3 Martin Stransky 2009-07-05 02:43:50 EDT
Wow, looks pretty seriously. Anyway, can you turn off all your extensions (run firefox in safe mode) and check official mozilla linux binaries too? (from mozilla.org).
Comment 4 Matěj Cepl 2009-07-05 20:15:24 EDT
Running in safe-mode is done by running

firefox -safe-mode

from the command line
Comment 5 Konstanty 2009-07-06 08:48:44 EDT
I am having troubles running firefox in safe mode and debug (well actually it runs OK - just that when it crashes I cannot obtain a stack trace)

Here are several crashes over the last 2 days:
(There were also a few more of "DW_FORM_strp pointing outside of .debug_str section [in module /usr/lib/debug/usr/lib64/xulrunner-1.9.1/libxul.so.debug]")

Program received signal SIGSEGV, Segmentation fault.
0x0000003f0683eae8 in JS_TraceChildren (trc=0x7fffffff12d0, 
    thing=0x7fffe6f83850, kind=0) at jsgc.cpp:2461
2461	        if (obj->map->ops->trace) {

Thread 49 (Thread 0x7fffe6cff910 (LWP 20157)):
DW_FORM_strp pointing outside of .debug_str section [in module /usr/lib/debug/usr/lib64/xulrunner-1.9.1/libxul.so.debug]

Thread 11 (Thread 0x7fffe5fff910 (LWP 20101)):
../../gdb/addrmap.c:368: internal-error: addrmap_find is not implemented yet for mutable addrmaps
A problem internal to GDB has been detected,
further debugging may prove unreliable.

DW_FORM_strp pointing outside of .debug_str section [in module /usr/lib/debug/usr/lib64/xulrunner-1.9.1/libxul.so.debug]

Program received signal SIGSEGV, Segmentation fault.
js_GetGCThingTraceKind (flags=<value optimized out>) at jsgc.cpp:1181
1181	    return MapGCFlagsToTraceKind(*THING_FLAGP(a, index));
DW_FORM_strp pointing outside of .debug_str section [in module /usr/lib/debug/usr/lib64/xulrunner-1.9.1/libxul.so.debug]
Comment 6 Konstanty 2009-07-06 08:49:14 EDT
Also, while running on the console there are many:
(firefox:31470): Gdk-WARNING **: XID collision, trouble ahead
Comment 7 Martin Stransky 2009-07-07 04:49:46 EDT
Okay, can you please try official mozilla binaries downloaded from mozilla.org?
Comment 8 Konstanty 2009-07-14 19:03:34 EDT
On mozilla.org there seems to only be 32bit builds of Firefox (this will require many new libraries to the one I am using from Fedora)
Comment 9 Martin Stransky 2009-07-15 03:18:23 EDT
Try a nightly x86_64 snapshot from: 

ftp://ftp.mozilla.org/pub/firefox/nightly/latest-firefox-3.5.x
Comment 10 Konstanty 2009-07-23 06:52:14 EDT
Thanks for that link.

I upgraded my system last week to new kernel, and also the new library as specified in bug 502274.

Both firefox normally and the Firefox nightly seem to run a long time without crashing (about 1 full day). The Firefox nightly (x86_64) crashed a few times, however I was running with the flash plugin:

(gdb) bt 
#0  0x0000000000000000 in ?? ()
#1  0x00007fffd2a8f59a in ?? ()
   from ~/.mozilla/plugins/libflashplayer.so
#2  0x00007fffd2bd7a19 in ?? ()
   from ~/.mozilla/plugins/libflashplayer.so
#3  0x00007fffd2da704c in ?? ()
   from ~/.mozilla/plugins/libflashplayer.so
#4  0x00007fffd2a913be in ?? ()
   from ~/.mozilla/plugins/libflashplayer.so
#5  0x00007fffd2a883d9 in ?? ()

Therefore I did not report anything here.

However there have also been 2 crashes of it crashing after I deleted the flash plugin. I will attach it to this bug.
Comment 11 Konstanty 2009-07-23 06:53:12 EDT
Created attachment 354838 [details]
Firefox crash in firefox nightly build (x86_64)

Unfortunately no debug info in this build - so back trace is not that interesting.
Comment 12 Matěj Cepl 2009-12-21 08:09:19 EST
(In reply to comment #11)
> Created an attachment (id=354838) [details]
> Firefox crash in firefox nightly build (x86_64)
> 
> Unfortunately no debug info in this build - so back trace is not that
> interesting.  

OK, this backtrace looks pretty useless. Backtrace in comment 5 kind of resembles the one in bug 544939. Martin, should that bug be closed as a duplicate of this one?
Comment 13 Martin Stransky 2010-03-09 09:27:09 EST
libflashplayer.so is a closed source flash plugin. Closing as CANTFIX. You may consider to install nspluginwrapper, it shields browser from plug-in failures.

Note You need to log in before you can comment on or make changes to this bug.