Bug 509681 - Pulseaudio mixer scaling incorrectly
Pulseaudio mixer scaling incorrectly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-04 21:05 EDT by Suchandra Thapa
Modified: 2009-08-01 14:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 19:52:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suchandra Thapa 2009-07-04 21:05:53 EDT
Description of problem:


Version-Release number of selected component (if applicable):

Name        : pulseaudio                   Relocations: (not relocatable)
Version     : 0.9.15                            Vendor: Fedora Project


How reproducible:

Everytime

Steps to Reproduce:
1. Open volume control in pulseaudio mixer
2. Decrease volume

  
Actual results:
Sound is muted when the volume is at 50% 

Expected results:
The sound should be at 50% of max volume

Additional info:
If I open up the gst-mixer and look at the master volume while changing the volume in pulseaudio's volume control, the master volume is at 0 when the pulseaudio volume is at 50%.  The master volume is at 100% when the pulseaudio volume is at 100% so it looks like the pulseaudio mixer changes are being scaled incorrectly.  The changes aren't being doubled because the pulseaudio volume at 75% doesn't correspond to a master volume of 50%.
Comment 1 Lennart Poettering 2009-07-22 19:52:58 EDT
The percentage scale is completely artificial. The PA and ALSA sliders are aligned based on the dB values, not the percentage. (though there is sometimes a contsnat shift, since PA always puts max amplification to 0dB while ALSA doesn't necessarily)
Comment 2 Suchandra Thapa 2009-07-22 21:02:27 EDT
I would disagree that this is not a bug.  When using the volume slider in the default gnome desktop, this means that the sound is turned off when the slider is in the middle.  Not only does this make it harder to adjust the sound but it just looks bad.
Comment 3 Lennart Poettering 2009-07-23 08:45:56 EDT
In F12 we changed mapping between dB an pixels a bit which should make sure that the volume drops to complete silence on most hw more "to the left" left of the slider.

Note You need to log in before you can comment on or make changes to this bug.