Bug 50969 - sound related errors with no sound adapter
sound related errors with no sound adapter
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-05 16:19 EDT by Gene Czarcinski
Modified: 2014-03-16 22:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-05 16:19:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2001-08-05 16:19:23 EDT
Description of Problem:
Roswell is installed (with X, etc) on a system with NO sound card
installed. An error occurs during halt/poweroff:

1. modprobe cannot locate Sound-slot-0
2.  aumix:  error opening mixer

Also, doing lsmod shows soundcore loaded.

How Reproducible:
everytime

Steps to Reproduce:
1. install Roswell with gnome, kde, etc.
2. bootup and login as root (do lsmod)
3. logout
4. select shutdown-halt

Actual Results:
error messages during shutdown (see above)

Expected Results:
no error messages

Additional Information:
You have do login (gnome session).  If you immediately just shutdown, then
no error messages
Comment 1 Bill Nottingham 2001-08-07 00:40:04 EDT
This is because of two things:

- the fix for bug #34758
- the fact that 'rmmod -a' doesn't run out of cron anymore

I believe turning off sound support in Gnome may stop this.
Comment 2 Gene Czarcinski 2001-08-07 01:53:52 EDT
Sound support was never turned on in gnome and esd is not started.  However,
something in gnome is loading the "soundcore" module.  If I rmmod soundcore
before logoff/shutdown, then the problem goes away.

This answer is OK for me but may bother some novice users.  I believe that
whatever in gnome is loading soundcore (in error) should be fixed.
Comment 3 Bill Nottingham 2001-08-07 02:00:12 EDT
Removing sound-properties from your gnome session should do it.
Comment 4 Gene Czarcinski 2001-08-07 05:40:30 EDT
Using gnomecc, I tried to remove everything I could.  Is there something else
because saying DON'T start esd still loads soundcore and results in the error.

Note You need to log in before you can comment on or make changes to this bug.