Bug 509709 - can't set volume grops via /etc/sysconfig/mkinitrd
can't set volume grops via /etc/sysconfig/mkinitrd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-05 08:41 EDT by Gerd v. Egidy
Modified: 2009-07-06 06:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-06 05:06:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to allow setting VG_LIST in /etc/sysconfig/mkinitrd (325 bytes, patch)
2009-07-05 08:41 EDT, Gerd v. Egidy
no flags Details | Diff

  None (edit)
Description Gerd v. Egidy 2009-07-05 08:41:45 EDT
Created attachment 350533 [details]
Patch to allow setting VG_LIST in /etc/sysconfig/mkinitrd

I install all RPMs into a central repository which is then synced out via rsync to all actual systems. So autodetection of needed modules and settings during mkinitrd does not work and I control what should be in there via entries into /etc/sysconfig/mkinitrd.

But currently you can't control the list of volume groups this way because the variable vg_list is zeroed before usage.

I've attached a small patch which allows to set the volume groups via VG_LIST from /etc/sysconfig/mkinitrd. This is the same way as already done for NET_LIST.

It would be nice if you could apply this patch to rawhide.
Comment 1 Hans de Goede 2009-07-06 05:06:29 EDT
Thanks for the patch. I've applied it and it is part of
mkinitrd-6.0.91 which will hit rawhide soon.

Notice that mkinitrd will be replaced with dracut in F-12, and your
time is thus probably better spend testing that and submitting patches
for it, see:
http://fedoraproject.org/wiki/Dracut
http://fedoraproject.org/wiki/Features/Dracut
http://www.harald-hoyer.de/personal/blog/dracut-0.3
Comment 2 Gerd v. Egidy 2009-07-06 06:03:20 EDT
Thanks for applying.

I already had Dracut on my radar for interesting projects to look at but didn't have the time yet. But I didn't know yet that it will be in F12 - so I'll take a look at it soon and make sure that my workflow is supported there too...

Note You need to log in before you can comment on or make changes to this bug.