Bug 509743 - Strange Alt key issue when guest connected by virt-manager or virt-viewer [NEEDINFO]
Strange Alt key issue when guest connected by virt-manager or virt-viewer
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtk-vnc (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Daniel Berrange
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-05 13:43 EDT by Mark Xie
Modified: 2014-06-02 09:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:17:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (yxie)


Attachments (Terms of Use)

  None (edit)
Description Mark Xie 2009-07-05 13:43:11 EDT
Description of problem:
The keyboards and mouse generates some special 'Alt' actions sometimes

Version-Release number of selected component (if applicable):
gtk-vnc-0.3.8-2.el5
virt-manager-0.6.1-5.el5
virt-viewer-0.0.2-3.el5


How reproducible:
100%

Steps to Reproduce:
It's an alt key issue. press alt for a while and the steps:
1, Start a guest(KVM, xen PV, xen FV, any kinds of RHEL guest will be ok.)
2, Move the mouse to the guest window, and let the virt-viewer window get the mouse focus.
3, Press the "Alt" and "F", "S",or "H"to open a menu, keeps it hold and press some keys several times (More than 5 keys pressed.)
4, Release the "Alt" try to input something into a text  file, the terminal,etc. the input will not correct, seems the Alt key have been pressed. Try to open some utilities or application by the mouse, the mouse do not work too.

But the issues are not stable and the the keyboard maybe can useable soon.
To back to a normal state:
1,open the guest by virt-manager and input something, then back to virt-viewer, the guest will back to a normal status.
2, let the mouse grab by the guest, then release it by press 'Ctrl + Alt', the guest will back to normal too.

  
Actual results:
Inline step 4.

Expected results:
The keyboard works as normal.

Additional info:
This issue also happens on virt-manager.
Comment 1 RHEL Product and Program Management 2009-11-06 14:08:18 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 3 RHEL Product and Program Management 2014-03-07 08:42:31 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 4 RHEL Product and Program Management 2014-06-02 09:17:06 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.