Bug 509754 - -n ${GOVERNOR} typo in /etc/init.d/cpuspeed
-n ${GOVERNOR} typo in /etc/init.d/cpuspeed
Status: CLOSED DUPLICATE of bug 505837
Product: Fedora
Classification: Fedora
Component: cpuspeed (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-05 15:44 EDT by Maciej Żenczykowski
Modified: 2009-07-06 13:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-06 09:51:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maciej Żenczykowski 2009-07-05 15:44:52 EDT
My box has an EIST capable cpu, but missing ACPI tables, hence frequency scaling doesn't work.

In /etc/init.d/cpuspeed the line:
        if [ -d ${cpu0freqd} -a -n ${GOVERNOR} ]; then
should be:
        if [ -d ${cpu0freqd} -a -n "${GOVERNOR}" ]; then
to prevent errors about ] misparsing when GOVERNOR is empty.

# rpm -q --whatprovides /etc/init.d/cpuspeed 
cpuspeed-1.5-8.fc11.x86_64

However, I believe this has actually been fixed in a non-pushed to updates version of cpuspeed.

At least:

# rpm -q --whatprovides /etc/init.d/cpuspeed 
cpuspeed-1.5-10.fc11.x86_64

doesn't seem to have this issue.
Comment 1 Jarod Wilson 2009-07-06 09:51:38 EDT
cpuspeed-1.5-10.fc11 was pushed to the updates repo last Wednesday.

*** This bug has been marked as a duplicate of bug 505837 ***
Comment 2 Maciej Żenczykowski 2009-07-06 13:13:49 EDT
# yum list extras
Loaded plugins: dellsysidplugin2, refresh-packagekit
Extra Packages
cpuspeed.x86_64                       1:1.5-10.fc11                    installed
...

So it doesn't seem to be live yet (I installed manually from koji).
Comment 3 Jarod Wilson 2009-07-06 13:26:09 EDT
You have stale repo data or something.

$ yum list cpuspeed
Loaded plugins: refresh-packagekit
Installed Packages
cpuspeed.x86_64                                                          1:1.5-9.fc11                                                           @updates
Available Packages
cpuspeed.x86_64                                                          1:1.5-10.fc11                                                          updates
Comment 4 Maciej Żenczykowski 2009-07-06 13:58:36 EDT
Yeah, it does seem that "rm -rf /var/cache/yum/*" has revealed a whole bunch of updates.

Sorry, for the bother.

Note You need to log in before you can comment on or make changes to this bug.