Bug 509774 - IcePodder 5.4 and svn will crash on Fedora 11
IcePodder 5.4 and svn will crash on Fedora 11
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
noarch Linux
low Severity high
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-07-06 02:50 EDT by Brian Wright
Modified: 2009-12-02 18:03 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-12-02 18:03:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brian Wright 2009-07-06 02:50:27 EDT
Description of problem:IcePodder will crash upon startup, does not display title screen

Version-Release number of selected component (if applicable): 5.4

How reproducible: Start icepodder from the command line.  Does not display titel screen but crashes immediately

Steps to Reproduce:
1. Download IcePodder from www.icepodder.com
2. Unpack tarball
3. Start icepodder 
Actual results:
IcePodder will crash with the following:

/usr/lib/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_core.py:14450: UserWarning: wxPython/wxWidgets release number mismatch                                           
  warnings.warn("wxPython/wxWidgets release number mismatch")
/usr/share/icepodder/ipodder/core.py:31: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  from   sha import *
/usr/share/icepodder/ipodder/history.py:23: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import logging,md5,time,os,threading,time
Traceback (most recent call last):
  File "CastPodderGui.py", line 3704, in <module>
  File "CastPodderGui.py", line 3693, in main
    ipodder = core.iPodder(config,state)
  File "/usr/share/icepodder/ipodder/core.py", line 1148, in __init__
    self.feeds = feeds.Feeds(self.config, self.state)
  File "/usr/share/icepodder/ipodder/feeds.py", line 400, in __init__
  File "/usr/share/icepodder/ipodder/feeds.py", line 830, in clean_state_database
    for key in state.iterkeys():
  File "/usr/share/icepodder/ipodder/state.py", line 228, in iterkeys
    return self.__shelf.iterkeys()
  File "/usr/lib/python2.6/_abcoll.py", line 337, in iterkeys
    return iter(self)
  File "/usr/lib/python2.6/bsddb/dbshelve.py", line 167, in __iter__
    return self.db.__iter__()
AttributeError: 'DB' object has no attribute '__iter__'

Expected results:
IcePodder should run normally

Additional info:

This bug is similar to Bug 453299 except it has to do with the error above.  My understanding is that IcePodder may only work with python2.5 after following some of the ubuntu forums where this error was reported against Ubuntu 9.04.  This podcast aggregator does download individual podcasts to different directories and runs scheduled checks, and is the only aggregator with these capabilities.  There aren't any python2.5 compat packages and my suspicion is that this may be the resolution as it was the resolution for IcePodder with Ubuntu 9.04, and I have verified this myself.
Comment 1 Petr Šplíchal 2009-08-18 07:55:34 EDT
Brian, thanks for your bug report. Can you please provide a few
details about the "svn" crashes? Thanks.
Comment 2 Dave Malcolm 2009-12-02 18:03:50 EST
Brian: thanks for this bug report. 

From my reading of the bug description, it looks like the svn code you downloaded from icepodder.com only works with Python 2.5, not with Python 2.6

We don't ship a 2.5 compatibility package in Fedora, as it's generally fairly easy to port code that targeted 2.5 to 2.6

It's probably possible to port icepodder to 2.6.  My guess is that doing so would be fairly easy for a skilled python coder, if it hasn't been done so already (perhaps someone already has since this bug was filed?)

The ideal here is probably to package icepodder as part of Fedora (assuming that it's legal to do so - anything multimedia can be a legal minefield, alas) - and, in so doing, you'd need to fix the 2.6 compat issue.

Requests for packaging are kept at: https://fedoraproject.org/wiki/Package_maintainers_wishlist
Please add this package to this list if it isn't there already; ideally, please volunteer and become a Fedora packager.

Setting the status of this report to "CLOSED:NOTABUG" as this isn't an issue with our python package per se.

Hope this is helpful; sorry I can't help more.

Note You need to log in before you can comment on or make changes to this bug.