Bug 509791 - cairo-dock-plug-ins has dependency on obsolete libxklavier
cairo-dock-plug-ins has dependency on obsolete libxklavier
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cairo-dock (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-06 04:49 EDT by birger
Modified: 2009-07-06 05:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-06 05:13:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description birger 2009-07-06 04:49:45 EDT
Description of problem:
A lot of rawhide packages cannot upgrade because cairo-dock-plug-ins is holding back upgrade of libxklavier.

Version-Release number of selected component (if applicable):
cairo-dock-plug-ins-2.0.6-1.fc12.x86_64

How reproducible:


Steps to Reproduce:
1. yum --skip-broken update
2.
3.
  
Actual results:
A lot of apps won't upgrade because of depsolving issues. The root cause is cairo-dock-plug-ins having a dependency on libxklavier.so.12()(64bit) where the new libxklavier package offers libxklavier.so.15()(64bit)

Expected results:
normal update

Additional info:
Comment 1 Mamoru TASAKA 2009-07-06 05:13:28 EDT
Well, the "current" cairo-dock (perhaps still in rpmfusion buildsys)
cairo-dock is 2.0.7-1.fc12 and this one is already rebuilt against
libxklavier 4.0:
http://buildsys.rpmfusion.org/plague-results/fedora-development-rpmfusion_free/cairo-dock/2.0.7-1.fc12/

(Note that cairo-dock is now under rpmfusion-free, not under Fedora,
 due to patent issue, so it is appreciated that
 cairo-dock related bugs are filed on rpmfusion bugzilla.)

Note You need to log in before you can comment on or make changes to this bug.