Bug 509799 - KVM: VM Migration fails during migration of concurrent multiple Guests,
KVM: VM Migration fails during migration of concurrent multiple Guests,
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
All Linux
high Severity high
: rc
: ---
Assigned To: Glauber Costa
Lawrence Lim
:
Depends On:
Blocks: 5.4/TechnicalNotes
  Show dependency treegraph
 
Reported: 2009-07-06 06:15 EDT by Oded Ramraz
Modified: 2014-03-25 20:58 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-30 10:21:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oded Ramraz 2009-07-06 06:15:34 EDT
Description of problem:

Usually when running Migration of multiple Guests using VDSM migration operation done 1 by 1 ( due to semaphore in VDSM ).
There is VDSM patch which increase the number of concurrent migration to Host #CPU cores.
When running VDSM with this patch on 2 cores Host everything works fine.
After running this script with 5 concurrent 1GB VM's migrations ( vm.MigrationSourceThread.setMaxOutgoingMigrations(5)) one of the migrations has failed and VM stuck on "Migration Source" status of source and "Up" on destination.




Version-Release number of selected component (if applicable):

Host Kernel:
2.6.18-152.el5

KVM version:
kvm-83-82.el5

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

My Host has 2 cores and 16GB Memory
Host specification:

Cores  : 2
Model  : Intel(R) Xeon(R) CPU            5150  @ 2.66GHz
Speed  : 1998
Comment 1 Dor Laor 2009-07-07 17:26:09 EDT
Can you collect the stack trace of the stuck source VM?
Comment 3 Glauber Costa 2009-07-10 12:37:58 EDT
Also, it would really help me to speak in terms of qemu, instead of vdsm here.

What is the qemu command line?

What's the output of the "info migration" command ?
Comment 4 Ludek Smid 2009-07-14 11:46:58 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
TBD
Comment 5 Subhendu Ghosh 2009-07-14 11:48:09 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1 @@
-TBD+Simultaneous migration of multiple guests is not supported at this time on KVM. Migration of multiple guests should be serialized.
Comment 8 Ryan Lerch 2009-08-18 00:30:45 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1 @@
-Simultaneous migration of multiple guests is not supported at this time on KVM. Migration of multiple guests should be serialized.+Simultaneous migration of multiple guests is currently not supported on KVM. Migration of multiple guests should be serialized.
Comment 9 Dor Laor 2009-08-18 05:03:44 EDT
I do not think the bug related to multiple migration in parallel.
There is no such limitation. It was probably a 'regular' migration bug.
I put it on_qa since I do not think it will exist at the moment.

I'm clearing the release notes since they may just confuse users of libvirt.
Oded/Lawrence, can you test multiple migrations?
Comment 10 Dor Laor 2009-08-18 05:03:44 EDT
Deleted Release Notes Contents.

Old Contents:
Simultaneous migration of multiple guests is currently not supported on KVM. Migration of multiple guests should be serialized.

Note You need to log in before you can comment on or make changes to this bug.