Bug 509846 - Does not offer to automatically install a required printer driver
Does not offer to automatically install a required printer driver
Status: CLOSED DUPLICATE of bug 509177
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
11
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-06 10:21 EDT by Jeff Tickle
Modified: 2009-07-06 10:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-06 10:45:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Tickle 2009-07-06 10:21:01 EDT
Description of problem:
When trying to install a HP LaserJet 1200, I get the following error: "Printer 'HP-LaserJet-1200' requires the 'hpijs' program but it is not currently installed.  Please install it before using this printer."  PackageKit is awesome and could be used to do this automatically, because this error could be very confusing for a less experienced user.


Version-Release number of selected component (if applicable): 1.1.7


How reproducible: Every time!


Steps to Reproduce:
1. Plug in a HP printer
2. Install the printer (autodetected, woot)
3. Behold the "error"!
  
Actual results:
Shows an error saying that you need to install this 'hpijs' program in order to use the printer.

Expected results:
Offer to install the needed program for the user.

Additional info:
Comment 1 Tim Waugh 2009-07-06 10:45:37 EDT
We had in fact been using PackageKit for just this purpose; but PackageKit changed its D-Bus API, and so this feature broke.

I've fixed system-config-printer to use the gpk-install-package-name program for this, and the package should appear in updates-testing shortly.

*** This bug has been marked as a duplicate of bug 509177 ***

Note You need to log in before you can comment on or make changes to this bug.