Bug 509903 - Evolution MAPI sucking up huge amounts of memory, eventually running out of RAM and crashing
Evolution MAPI sucking up huge amounts of memory, eventually running out of R...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On: 505661
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-06 15:11 EDT by Jonathan Kamens
Modified: 2009-07-06 16:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 505661
Environment:
Last Closed: 2009-07-06 16:36:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 587923 None None None Never

  None (edit)
Description Jonathan Kamens 2009-07-06 15:11:25 EDT
As described below, evolution with MAPI no longer crashing on startup, but now sucking up huge amounts of memory and CPU, eventually running out of memory and crashing.

+++ This bug was initially created as a clone of Bug #505661 +++

...
--- Additional comment from jik@kamens.brookline.ma.us on 2009-07-06 14:38:23 EDT ---

Startup crash gone.  Now other issues.  Got it to crash twice after setting up a MAPI account.  Unfortunately, can't replicate that crash with debuginfo packages installed.  However, now evolution is consuming a huge amount of RAM (1.5GB resident, >3GB total virtual size) and sucking a huge amount of CPU.  I suspect that the previous two crashes were out-of-memory issues, since I just got this:

Glib-ERROR **: gmim.c:175:failed to allocate 65536 bytes
aborting...

I'm pretty sure evolution shouldn't need >3GB of RAM just to read my email.  Something is definitely still wrong here.
Comment 1 Matthew Barnes 2009-07-06 16:36:37 EDT
Moving this upstream for better visibility.  Please see [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=587923

Note You need to log in before you can comment on or make changes to this bug.