Bug 509907 - Libraries 'missing'
Libraries 'missing'
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nx (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-06 15:49 EDT by Matt Castelein
Modified: 2009-07-31 13:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-25 10:18:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Castelein 2009-07-06 15:49:28 EDT
ldd says there are missing libraries in nx:

-bash-4.0$ ldd /usr/libexec/nx/nxagent
        linux-vdso.so.1 =>  (0x00007fff44fff000)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007f471a148000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007f4719f36000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007f4719bfd000)
        libz.so.1 => /lib64/libz.so.1 (0x00007f47199e8000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f4719764000)
        libXpm.so.4 => /usr/lib64/libXpm.so.4 (0x00007f4719553000)
        libXcomp.so.3 => not found
        libXcompext.so.3 => not found
        libXcompshad.so.3 => not found
        libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00007f471934a000)
        libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00007f4719145000)
        libXtst.so.6 => /usr/lib64/libXtst.so.6 (0x00007f4718f3f000)
        libXdamage.so.1 => /usr/lib64/libXdamage.so.1 (0x00007f4718d3d000)
        libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00007f4718b35000)
        libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x00007f4718933000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f47185c5000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007f47183c3000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007f47181a8000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f4717fa4000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f471a3e2000)

the 'missing' files are located in /usr/lib64/nx/ where evidently they cannot be found.
Comment 1 Matt Castelein 2009-07-06 15:55:49 EDT
cp -n /usr/lib64/nx/* /usr/lib64 fixes this quite nicely.. (some libraries exist in /usr/lib64/ and /usr/lib64/nx/ and they are NOT the same...)
Comment 2 Matt Castelein 2009-07-06 16:57:49 EDT
I guess what this really needs is a /etc/ld.so.conf.d/nx-x86_64.conf containing:
/usr/lib64/nx

followed by a run of ldconfig (preceded in my case by a bit of cleanup)
Comment 3 Matt Castelein 2009-07-22 21:51:19 EDT
It appears some of the files in the RPM need to be turned into symlinks also, as follows:

libXcompext.so.3 -> libXcompext.so.3.3.0
libXrender.so.1 -> libXrender.so.1.2.2
libXext.so.6 -> libXext.so.6.4
libXcomp.so.3 -> libXcomp.so.3.3.0
libX11.so.6 -> libX11.so.6.2
libXcompshad.so.3 -> libXcompshad.so.3.3.0
Comment 4 Axel Thimm 2009-07-25 09:30:20 EDT
(In reply to comment #0)
> ldd says there are missing libraries in nx:
> 
> -bash-4.0$ ldd /usr/libexec/nx/nxagent
> [...]
>         libXcomp.so.3 => not found
>         libXcompext.so.3 => not found
>         libXcompshad.so.3 => not found
> [...]
> 
> the 'missing' files are located in /usr/lib64/nx/ where evidently they cannot
> be found.  

This is on purpose as these libs confuse the standard xorg libs and had to be hidden away. /usr/libexec contains executables that are supposed to not be used directly, this is why a direct ldd on them shows funny results.

In fact it once did not hide the modified libs away and even messed up with the buildsystem.

If the ldd was you sole problem, then this bug is closed, but I suspect the ldd is just the tip of the iceberg? What problems do you have that led you to ldd'ing the libexec bits?
Comment 5 Matt Castelein 2009-07-25 10:07:41 EDT
What happened was that after I installed nx packages, nxagent would not start, due to the 'missing' libraries.  I fixed it by going through the steps I outlined in comment #2 and comment #3.
Comment 6 Matt Castelein 2009-07-25 10:14:46 EDT
I will try to put things back the way they were by reinstalling everything, and retest.  I have had several issues with nx and I am not sure which may be related.

Note You need to log in before you can comment on or make changes to this bug.