Bug 509925 - kvm messages: cpu0 unimplemented perfctr
kvm messages: cpu0 unimplemented perfctr
Status: CLOSED DUPLICATE of bug 507085
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
All Linux
low Severity low
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
hp:dl785solblk
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-06 17:56 EDT by Aron Griffis
Modified: 2015-02-16 12:08 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-23 06:09:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aron Griffis 2009-07-06 17:56:55 EDT
Description of problem:
Every time I start a virtual machine on my barcelona-based DL785 I see these messages on the console:

kvm: 18879: cpu0 unimplemented perfctr wrmsr: 0xc0010004 data 0x0
kvm: 18879: cpu0 unimplemented perfctr wrmsr: 0xc0010000 data 0x130076
kvm: 18879: cpu0 unimplemented perfctr wrmsr: 0xc0010004 data 0xffffffffffdce750
kvm: 18879: cpu0 unimplemented perfctr wrmsr: 0xc0010000 data 0x530076

Is this a real problem or debug noise? If the latter then perhaps it shouldn't be put on the console

Version-Release number of selected component (if applicable):
RHEL 5.4 beta
kernel-2.6.18-155.el5.x86_64

Additional info:
$ head /proc/cpuinfo 
processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 16
model		: 2
model name	: Quad-Core AMD Opteron(tm) Processor 8356
stepping	: 3
cpu MHz		: 2300.085
cache size	: 512 KB
physical id	: 0
siblings	: 4
core id		: 0
cpu cores	: 4
apicid		: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 5
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc nonstop_tsc pni cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy altmovcr8 abm sse4a misalignsse 3dnowprefetch osvw
bogomips	: 4600.16
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 48 bits physical, 48 bits virtual
power management: ts ttp tm stc 100mhzsteps hwpstate [8]
Comment 1 Roel Gloudemans 2009-07-16 03:08:06 EDT
Seeing this too on my Intel based box

kvm: 17024: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
kvm: 17024: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0xffdc7bc3
kvm: 17024: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x530079
kvm: 17024: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
kvm: 17024: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0xffdc7bf1
kvm: 17024: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x530079

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Core(TM)2 Duo CPU     E6550  @ 2.33GHz
stepping        : 11
cpu MHz         : 1998.000
cache size      : 4096 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
apicid          : 0
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni ds_cpl vmx smx est tm2 cx16 xtpr lahf_lm
bogomips        : 4655.10
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:
Comment 2 Yaniv Kaul 2009-07-23 06:09:42 EDT

*** This bug has been marked as a duplicate of bug 507085 ***
Comment 3 Joseph Shraibman 2009-09-24 16:23:26 EDT
I can't access bug #507085. Is it safe to ignore these messages for now?
Comment 4 Jean-Francois Saucier 2009-10-07 13:41:28 EDT
I have the same problem and I can't access bug #507085 too... Can I have more informations on this?

It's really a blocker bug here cause our guests VM crash just after seeing this in the log.
Comment 5 Tim Hughes 2009-11-02 09:09:32 EST
I am seeing the same issue on HP DL380 G5 
The following appears on the console output, doesn't appear to affect anything other than make me think something is wrong 

kvm: 14273: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
kvm: 14273: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0xffd4c44c
kvm: 14273: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x530079
kvm: 14273: cpu1 unimplemented perfctr wrmsr: 0x186 data 0x130079
kvm: 14273: cpu1 unimplemented perfctr wrmsr: 0xc1 data 0xffd4c44c
kvm: 14273: cpu1 unimplemented perfctr wrmsr: 0x186 data 0x530079



We are running RHEL 5.4 
kernel 2.6.18-164.2.1.el5 
kvm-83

Would be nice to be able to see bug #507085 to give us some idea of the progress on this.
Comment 6 Mohammed Arafa 2010-01-26 05:53:03 EST
sony vaio z720d with fedora12 x86_64 - updated daily.

was trying to do an oracle db upgrade to a 2 node RAC when it crashed in the middle. 
its reproducable:

Jan 26 12:08:46 laptopmarafa kernel: kvm: 9067: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
Jan 26 12:08:46 laptopmarafa kernel: kvm: 9067: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0xffd97008
Jan 26 12:08:46 laptopmarafa kernel: kvm: 9067: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x530079
Jan 26 12:42:24 laptopmarafa kernel: kvm: 9067: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
Jan 26 12:42:24 laptopmarafa kernel: kvm: 9067: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0xffd97008
Jan 26 12:42:24 laptopmarafa kernel: kvm: 9067: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x530079
Jan 26 12:42:24 laptopmarafa kernel: kvm: 9099: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
Jan 26 12:42:24 laptopmarafa kernel: kvm: 9099: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0xffd97008
Jan 26 12:42:24 laptopmarafa kernel: kvm: 9099: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x530079


12.08 and 12.42 are the times of the 2 crashes today

Note You need to log in before you can comment on or make changes to this bug.