This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 509938 - /var/lock not writable?
/var/lock not writable?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: filesystem (Show other bugs)
11
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-06 21:05 EDT by Matt Castelein
Modified: 2009-07-07 09:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-07 09:44:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Castelein 2009-07-06 21:05:17 EDT
Description of problem: I have a program which has recently begun complaining that /var/lock is not writable.  Since it was working before, I can only guess that either modes or owners have changed on /var/lock, or that I had changed them and the update to filesystem-2.4.21-1.fc11.x86_64 changed them back.  I am filing this report in the hopes of finding out which it is.

Version-Release number of selected component (if applicable):
filesystem-2.4.21-1.fc11.x86_64

How reproducible:
always

Actual results:
Program complains, /var/lock is not writable

Expected results:
Normal program execution
Comment 1 Ondrej Vasik 2009-07-07 08:48:09 EDT
Directory /var/lock should have 0775 root:lock . That's expected behaviour. So if you want to write to /var/lock, you should be either root or member or lock group. Could you please add more informations what's wrong from your opinion? Be more specific which program does complain - I guess it's more issue of that program than issue of root:lock 0775 rights on /var/lock.
Comment 2 Matt Castelein 2009-07-07 09:44:45 EDT
OK, if this is normal then the app needs to be modified to add it's non-privileged user to the lock group.  I'll take it up from that side.

Note You need to log in before you can comment on or make changes to this bug.