Bug 509944 - Para-virt guest failed to reboot (xen)
Para-virt guest failed to reboot (xen)
Status: CLOSED DUPLICATE of bug 507765
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-06 22:51 EDT by Qunfang Zhang
Modified: 2009-12-14 16:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-07 15:12:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Failed to restart the vm (21.18 KB, image/png)
2009-07-06 22:51 EDT, Qunfang Zhang
no flags Details

  None (edit)
Description Qunfang Zhang 2009-07-06 22:51:27 EDT
Created attachment 350725 [details]
Failed to restart the vm

Description of problem:
I reboot a virtual machine(para-virt)  using two different methods: click the reboot button and input reboot in terminal of the guest. But the vm can't restart successfully with both methods. 
 After reboot, the vm still run but can't restart, and there's a prompt
says: Console not configured for guest"(Please catch the attachment). So I click
the "Hardware" tab, and find "Display" disappears. But if I force off this vm,
and run it again, it will restart successfully. And the "Display" hardware will
appear again.


Version-Release number of selected component (if applicable):
Host: RHEL5.4Client-x86_64
virt-manager -0.6.1-4.el5
xen-3.0.3-88.el5
libvirt-0.6.3-11.el5


How reproducible:
Always

Steps to Reproduce:
1.Create a vm (xen)
2.Reboot the guest,using reboot button or input "reboot" in the guest's
terminal
  
Actual results:
The vms can't restart successfully

Expected results:
The vms can restart successful


Additional info:

#view /etc/xen/pv

name = "pv"
uuid = "5887b39d-aaa4-f1ab-8ebd-df841c6a581a"
maxmem = 1024
memory = 1024
vcpus = 2
bootloader = "/usr/bin/pygrub"
on_poweroff = "destroy"
on_reboot = "restart"
on_crash = "restart"
vfb = [ "type=vnc,vncunused=1,keymap=en-us" ]
disk = [ "tap:aio:/var/lib/xen/images/pv-i386.img,xvda,w" ]
vif = [ "mac=00:16:36:42:d6:96,bridge=xenbr0,script=vif-bridge" ]
Comment 1 Cole Robinson 2009-07-07 15:12:09 EDT

*** This bug has been marked as a duplicate of bug 507765 ***

Note You need to log in before you can comment on or make changes to this bug.