Bug 509957 - Cannot upgrade from Fedora 10 to Fedora 11: Error processing drive sdb...
Cannot upgrade from Fedora 10 to Fedora 11: Error processing drive sdb...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 02:46 EDT by Paul Kennedy
Modified: 2015-04-19 20:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 09:42:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File requested in Comment #5. (512 bytes, application/octet-stream)
2009-07-13 09:02 EDT, Paul Kennedy
no flags Details

  None (edit)
Description Paul Kennedy 2009-07-07 02:46:01 EDT
Description of problem:
Cannot upgrade from Fedora 10 to Fedora 11. 
When running installer from Fedora 11 DVD, a dialog box displays this message:

Error processing drive sdb Maybe it needs to be reinitialized. YOU WILL
LOSE ALL DATA ON THIS DRIVE

+----------------+         +---------------------+
|  IGNORE drive  |         | Re-initialize drive |
+----------------+         +---------------------+




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

[root@Dell-L733r ~]# fdisk -l

Disk /dev/sdb: 20.0 GB, 20000000000 bytes
255 heads, 63 sectors/track, 2431 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00083270

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1          25      200781   83  Linux
/dev/sdb2              26        2491    19808145   8e  Linux LVM
Comment 1 Chris Lumens 2009-07-07 09:55:15 EDT
Please attach /tmp/storage.log to this bug report.  Can you also see what "parted /dev/sdb p" has to say?  Internally, anaconda's using libparted for all this stuff.  If parted itself also has a problem reading the disk, that's helpful in narrowing down where the problem is occurring.  Thanks.
Comment 2 Paul Kennedy 2009-07-07 23:21:23 EDT
There is no /tmp/storage.log available.

I ran "parted /dev/sdb p":
[root@Dell-L733r /]# parted /dev/sdb p
Error: Can't have a partition outside the disk!
Comment 3 Chris Lumens 2009-07-08 11:13:24 EDT
Yeah, something's definitely off here.  fdisk thinks your disk ends at cylinder 2431, but that your second partition ends at 2491.  parted simply refuses to play along with that.  Do you have any idea how your disk ended up in this configuration?
Comment 4 Paul Kennedy 2009-07-08 13:35:52 EDT
No idea on that. I did a clean install using f10 dvd. That's it.
Comment 5 Joel Andres Granados 2009-07-13 07:58:40 EDT
- Can you post the first 512 bytes of your disk?  You can do this by executing `dd if=/dev/sdb of=/tmp/first_512_bytes bs=512 count=1` and then attaching the resulting file to the bug.

- What application did you use previously to partition the device.

- In what operating system did you partition the device.

- What does `fdisk -l /dev/sdb' say.
Comment 6 Paul Kennedy 2009-07-13 09:02:40 EDT
Created attachment 351471 [details]
File requested in Comment #5.

/tmp/first_512_bytes is attached.

Other information
=================

In response to:
- What application did you use previously to partition the device?
- In what operating system did you partition the device.

Can't say for sure. I had installed a variety of Linux distros before this. Thought I had done a complete reformat using Fedora 10, but cannot say for certain.

- What does `fdisk -l /dev/sdb' say?

[root@Dell-L733r tmp]# fdisk -l /dev/sdb

Disk /dev/sdb: 20.0 GB, 20000000000 bytes
255 heads, 63 sectors/track, 2431 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00083270

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1          25      200781   83  Linux
/dev/sdb2              26        2491    19808145   8e  Linux LVM
Comment 7 Erik Heckers 2009-07-22 08:55:56 EDT
Hello!

The same interactive dialog stops all of our fully automated network
installations with Fedora 11.

To force clients to boot from network and not the HDD we clear
the bootblock first, so it is all zeros in our setup.

The section in our kickstart config file for the disk setup is this:

zerombr yes
clearpart --all --drives=sda
part /boot --fstype ext3 --size=100 --ondisk=sda
part swap --size=4096
part / --fstype ext3 --size=1024 --grow --ondisk=sda
reboot

With "zerombr" and "clearpart" it should be obvious, that we
want to reinitialize the drive without any warning that stops
the automated installation procedure.
Comment 8 Joel Andres Granados 2009-07-22 09:35:08 EDT
Erik:
The matter you describe in comment #7 is not related to the issue. I am sure that there is a bug already open for this.... Sorry but I can't find it anywhere.  If you are also unsuccessful at finding the issue, pls feel free to open a bug.
Comment 9 Joel Andres Granados 2009-07-22 09:42:36 EDT
Paul:
Your label (partition tabel) is broken.  there is a partition that thinks it ends somewhere past the device size.  This could have happened when partitioning the device in another operating system.  different OSs think differently of devices (for some unknown, to  me, reason).

My suggestion to you is to:
a. if you don't have important data in the disk, format it completely (dd if=/dev/zero of=DEVICE bs=1M count=2) and start a fresh installation of whatever your favorite distro might be :)

b. if you have important info, put it somewhere else and do a.

c. If you don't have an additional place to put it, you might try shrinking the last partition in your drive.  you can use fdisk and file system commands like resize2fs.

I prefer a or b.  c is to prone to error.

Closing this bug as parted can't really do anything here.
Comment 10 Paul Kennedy 2009-07-22 10:32:17 EDT
Joel:

It is not so much that there is important data, but applications that I have installed. From the sounds of it, because I have paraded several distros through this box until settling on Fedora, it appears that the partitioning is a little hosed. So, I'll bite the bullet and do as suggested in "a" in Comment #9. As a matter of troubleshooting, I'll install Fedora 10 and try an update after that. Thanks very much for your help.

Paul
Comment 11 Paul Kennedy 2009-07-24 09:44:49 EDT
Just for the record:
I erased the hard drive while running on Fedora 11 Live CD. Could not get format to happen with "a" in Comment #9. After that, installed Fedora 10 and let it format the drive during install. Then, I loaded Fedora 11 DVD and booted. Anaconda found the drive and is upgrading to Fedora 11 now.

Note You need to log in before you can comment on or make changes to this bug.