Bug 509974 - The computer hangs when starting blender
The computer hangs when starting blender
Status: CLOSED DUPLICATE of bug 509519
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
: 509805 511335 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 04:23 EDT by Patrik Andersson
Modified: 2009-08-16 05:01 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-02 12:37:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The only error message I could recieve (105 bytes, text/plain)
2009-07-07 05:03 EDT, Patrik Andersson
no flags Details

  None (edit)
Description Patrik Andersson 2009-07-07 04:23:36 EDT
Description of problem:
The computer hangs when starting blender.


Version-Release number of selected component (if applicable):
Up2date system 2009-07-06(YYYY-MM-DD), It worked fine, before the update around 2009-07-05.

How reproducible:
Start blender on a machine with Intel GM965  chipset, fails every time.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Nicolas Chauvet (kwizart) 2009-07-07 04:31:49 EDT
get the one in updates-testing
Comment 2 Patrik Andersson 2009-07-07 04:32:52 EDT
get the one in updates-testing, do you mean blender-version?
Comment 3 Nicolas Chauvet (kwizart) 2009-07-07 04:43:47 EDT
yum update --enablerepo=updates-testing blender\*

Then please open a terminal and type:
blender

This will provide some info, then please attach them here as text file.
Comment 4 Patrik Andersson 2009-07-07 05:02:40 EDT
Nothing happened when I ran the yum update command.

when I ran blender this appear before the normal starting message:

[patrik@localhost ~]$ blender
/usr/bin/blender: line 68: [: too many arguments
^C
[patrik@localhost ~]$ 

I needed to interrupt it before the computer crashes.

The line above appear before two other lines the says something like Blender version 2.48a, and python is loaded, then the computer hangs.
Comment 5 Patrik Andersson 2009-07-07 05:03:33 EDT
Created attachment 350754 [details]
The only error message I could recieve
Comment 6 Nicolas Chauvet (kwizart) 2009-07-07 05:06:23 EDT
(In reply to comment #3)
> yum update --enablerepo=updates-testing blender\*
Can you accurately look at the command ?
Comment 7 Patrik Andersson 2009-07-07 05:17:54 EDT
Like this?

[root@localhost yum.repos.d]# yum update --enablerepo=updates-testing blender\*
Loaded plugins: dellsysidplugin2, refresh-packagekit
updates-testing                                          | 2.3 kB     00:00     
Setting up Update Process
No Packages marked for Update
[root@localhost yum.repos.d]# 

Can I just download it from
http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/11/i386/
?
Comment 8 Nicolas Chauvet (kwizart) 2009-07-07 05:23:01 EDT
So which version of blender do you ends to have at the begining of the report and now ?
rpm -q blender
Comment 9 Patrik Andersson 2009-07-07 05:24:36 EDT
[patrik@localhost ~]$ rpm -q blender
blender-2.48a-21.fc11.i586
[patrik@localhost ~]$
Comment 10 Patrik Andersson 2009-07-07 05:29:01 EDT
And now I've got:
[patrik@localhost ~]$ rpm -q blender
blender-2.49a-1.fc11.i586
[patrik@localhost ~]$
Comment 11 Nicolas Chauvet (kwizart) 2009-07-07 05:31:04 EDT
Something is definitely broken with you repository configuration:
So what is the error with the new blender ?
Comment 12 Patrik Andersson 2009-07-07 05:43:54 EDT
No error-messages appear, it says compiled with python, and python is loaded, then the computer hangs.
Comment 13 Nicolas Chauvet (kwizart) 2009-07-07 05:53:28 EDT
Please have a look at:
https://fedoraproject.org/wiki/Common_F11_bugs#Miscellaneous_problems_with_Intel_graphics_adapters

Since your computer hangs, I would say this problem is a little different than #507282
Comment 14 Patrik Andersson 2009-07-07 06:03:41 EDT
Yes I agree, that problem I also had, I solve it by running blender in fullscreen. I downloaded a 2.5(0) build, and there all components were drawn correctly... by the way, the computer hangs when I starting the 2.5(0) build now too, so there is something under the hood.

In sunday I could run blender smothly, both version 2.48a, and 2.5(0), but then I did an update, I don't know which packages which become updated, probably manipulating something that may interfered with the intel-drivers
Comment 15 Patrik Andersson 2009-07-07 06:05:41 EDT
sorry for my english, haven't used it for a while...
Comment 16 pankaj pandey 2009-07-07 09:19:08 EDT
*** Bug 509805 has been marked as a duplicate of this bug. ***
Comment 17 pankaj pandey 2009-07-07 09:21:47 EDT
I've posted a workaround in my previous bug report Bug #509805
Also included some kernel error messages. This problem is not only with blender, some other apps too have this problem.
Comment 18 Patrik Andersson 2009-07-07 18:44:40 EDT
I've got the same bug message:

Jul  7 10:59:15 localhost kernel: ------------[ cut here ]------------
Jul  7 10:59:15 localhost kernel: kernel BUG at drivers/gpu/drm/i915/i915_gem.c:2136!
Jul  7 10:59:15 localhost kernel: invalid opcode: 0000 [#1] SMP 
Jul  7 10:59:15 localhost kernel: last sysfs file: /sys/devices/pci0000:00/0000:00:1c.5/0000:0c:00.0/rfkill/rfkill0/state
Jul  7 10:59:15 localhost kernel: Modules linked in: fuse rfcomm bridge stp llc bnep sco l2cap tun sunrpc nf_conntrack_ipv6 ip6t_ipv6header ip6t_REJECT ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq dm_multipath uinput arc4 ecb iwlagn firewire_ohci firewire_core snd_hda_codec_si3054 crc_itu_t snd_hda_codec_realtek ricoh_mmc sdhci_pci sdhci mmc_core btusb bluetooth snd_hda_intel snd_hda_codec snd_hwdep pcspkr snd_pcm i2c_i801 snd_timer iwlcore lib80211 iTCO_wdt iTCO_vendor_support snd soundcore snd_page_alloc tg3 wmi compal_laptop mac80211 cfg80211 joydev ata_generic pata_acpi i915 drm i2c_algo_bit i2c_core video output [last unloaded: microcode]
Jul  7 10:59:15 localhost kernel:
Jul  7 10:59:15 localhost kernel: Pid: 3593, comm: blender.bin Not tainted (2.6.29.5-191.fc11.i586 #1) ZNOTE                                      
Jul  7 10:59:15 localhost kernel: EIP: 0060:[<f83e0a2e>] EFLAGS: 00210202 CPU: 1
Jul  7 10:59:15 localhost kernel: EIP is at i915_gem_object_get_fence_reg+0x22a/0x607 [i915]
Jul  7 10:59:15 localhost kernel: EAX: 00021af4 EBX: f17a1300 ECX: f6289000 EDX: 00000010
Jul  7 10:59:15 localhost kernel: ESI: ef5e2c00 EDI: f6226000 EBP: f1435dc4 ESP: f1435d90
Jul  7 10:59:15 localhost kernel: DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
Jul  7 10:59:15 localhost kernel: Process blender.bin (pid: 3593, ti=f1434000 task=ef578ca0 task.ti=f1434000)
Jul  7 10:59:15 localhost kernel: Stack:
Jul  7 10:59:15 localhost kernel: 00000010 f17a1300 00021af4 ef5e2c00 f6226134 f6226134 c0707761 ef552200
Jul  7 10:59:15 localhost kernel: f6289000 00000003 ef552200 f1435e20 f17a1300 f1435df4 f83e2546 b7f5e000
Jul  7 10:59:15 localhost kernel: b7f5e000 f6226000 01435df4 f1f14e18 f6289000 f6289014 f0576b7c fff8ed78
Jul  7 10:59:15 localhost kernel: Call Trace:
Jul  7 10:59:15 localhost kernel: [<c0707761>] ? _spin_lock+0xd/0x10
Jul  7 10:59:15 localhost kernel: [<f83e2546>] ? i915_gem_fault+0xa0/0x102 [i915]
Jul  7 10:59:15 localhost kernel: [<c048aa25>] ? __do_fault+0x41/0x342
Jul  7 10:59:15 localhost kernel: [<f83847e5>] ? drm_clflush_pages+0x55/0x6c [drm]
Jul  7 10:59:15 localhost kernel: [<c05ce868>] ? agp_flush_chipset+0x14/0x16
Jul  7 10:59:15 localhost kernel: [<f8389f01>] ? drm_agp_chipset_flush+0x16/0x18 [drm]
Jul  7 10:59:15 localhost kernel: [<f83ded22>] ? i915_gem_object_flush_cpu_write_domain+0x21/0x2c [i915]
Jul  7 10:59:15 localhost kernel: [<c048aff0>] ? handle_mm_fault+0x2ca/0x6fb
Jul  7 10:59:15 localhost kernel: [<c0709741>] ? do_page_fault+0x2b3/0x653
Jul  7 10:59:15 localhost kernel: [<c0532929>] ? inode_has_perm+0x60/0x6a
Jul  7 10:59:15 localhost kernel: [<c0485daa>] ? vma_prio_tree_insert+0x1f/0x8c
Jul  7 10:59:15 localhost kernel: [<c0707b31>] ? unlock_kernel+0x28/0x2b
Jul  7 10:59:15 localhost kernel: [<c04aa488>] ? vfs_ioctl+0x62/0x74
Jul  7 10:59:15 localhost kernel: [<c04aad29>] ? do_vfs_ioctl+0x480/0x4ba
Jul  7 10:59:15 localhost kernel: [<c04a6b98>] ? path_put+0x1a/0x1d
Jul  7 10:59:15 localhost kernel: [<c0464fff>] ? audit_syscall_exit+0xec/0x101
Jul  7 10:59:15 localhost kernel: [<c070948e>] ? do_page_fault+0x0/0x653
Jul  7 10:59:15 localhost kernel: [<c0707be7>] ? error_code+0x77/0x80
Jul  7 10:59:15 localhost kernel: Code: ff 85 c0 0f 84 a7 fe ff ff e9 f2 03 00 00 89 75 d8 8b 5d d0 83 7e 10 00 75 11 8b 4d dc 8b 09 89 4d e0 f7 41 44 be ff ff ff 74 04 <0f> 0b eb fe 8b 7d ec 8b 75 e0 8b 87 ec 00 00 00 8b 56 20 85 c0 
Jul  7 10:59:15 localhost kernel: EIP: [<f83e0a2e>] i915_gem_object_get_fence_reg+0x22a/0x607 [i915] SS:ESP 0068:f1435d90
Jul  7 10:59:15 localhost kernel: ---[ end trace 4f20e7072c5c0288 ]---
Comment 19 Thomas Spura 2009-07-11 13:03:21 EDT
This could be a duplicate of bug #509519
Comment 20 pankaj pandey 2009-07-11 13:55:02 EDT
Anyone having this bug *should* try the fixes i mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=509805#c1 work. Maybe you should try to ask someone suffering the bug #509519 to also try running blender and check if there's an immediate hang. Anyways the drirc fix works for me, albeit some drop in performance.
Comment 21 pankaj pandey 2009-07-11 15:13:59 EDT
Ok after checking the other bug report i can verify that the following .drirc file fixes the problem

[pankaj@localhost ~]$ cat .drirc 
<driconf>
    <device screen="0" driver="i965">
        <application name="Default">
            <option name="texture_tiling" value="false" />
        </application>
    </device>
</driconf>
Comment 22 Patrik Andersson 2009-07-11 18:59:35 EDT
I can confirm the solution in comment #21 above.

Is it possible to change the <application name="Default"> to something like <application name="Blender">?
Comment 23 pankaj pandey 2009-07-12 00:30:36 EDT
Ya sure you can do that. Here's the modified file which will apply the settings only for blender. However note that any application using texture tiling will probably fail. So i keep it as system default. Depends on whether you use any such other program.
Also "yum install driconf" will give you a gui to modify the dri configuration files.

[pankaj@localhost ~]$ cat .drirc 
<driconf>
    <device screen="0" driver="i965">
        <application name="Default">
        </application>
        <application name="Blender" executable="blender.bin">
            <option name="texture_tiling" value="false" />
        </application>
    </device>
</driconf>
Comment 24 Matěj Cepl 2009-07-24 03:07:49 EDT
*** Bug 511335 has been marked as a duplicate of this bug. ***
Comment 25 Felix Möller 2009-08-02 12:24:21 EDT
this seems to be a dupe of bug #509519 in my opinion. 

the .drirc from comment #21 fixes my google-earth too...
Comment 26 Thomas Janssen 2009-08-02 12:37:00 EDT

*** This bug has been marked as a duplicate of bug 509519 ***
Comment 27 pankaj pandey 2009-08-03 05:54:17 EDT
This bug has been marked duplicate of the bug https://bugzilla.redhat.com/show_bug.cgi?id=509519 , however the comment https://bugzilla.redhat.com/show_bug.cgi?id=509519#c29 in that bug make me believe that its not the case. Someone needs to verify it.
Comment 28 pankaj pandey 2009-08-16 00:44:09 EDT
FYI this seems to be fixed in kernel-2.6.30.5-28.rc2.fc11 (I tested)
https://admin.fedoraproject.org/updates/kernel-2.6.30.5-28.rc2.fc11
Comment 29 Erick 2009-08-16 03:47:16 EDT
Just tested kernel-2.6.30.5-28.rc2.fc11.i686.PAE. Alas, no luck: video still hangs when played using Intel driver. Using GL driver everything is fine.
Comment 30 pankaj pandey 2009-08-16 05:01:58 EDT
Yeah, you know what someone goofed up by marking this bug a duplicate of bug #509519 . I can confirm for sure that the X crash due to blender is gone. I donno how to unduplicate this bug from that bug. Someone must confirm and do it. You can keep that bug open. I'm not even sure what that bug is exactly about. Sure there are a HUGE number of intel bugs out there.

Note You need to log in before you can comment on or make changes to this bug.